profiles/features/musl: mask app-crypt/mit-krb5-appl
[gentoo/gentoo.git] / games-arcade / conveysdl / conveysdl-1.3-r2.ebuild
blob54d79cf9b6209d19f4513bb26c0f49aa469648df
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit desktop flag-o-matic toolchain-funcs
8 DESCRIPTION="Guide the blob along the conveyer belt collecting the red blobs"
9 HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
10 SRC_URI="
11         mirror://gentoo/${P/-/.}.tar
12         https://dev.gentoo.org/~ionen/distfiles/${PN}.png"
13 S="${WORKDIR}"
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
19 RDEPEND="
20         media-libs/libsdl[sound,video]
21         media-libs/sdl-mixer"
22 DEPEND="${RDEPEND}"
23 BDEPEND="virtual/pkgconfig"
25 PATCHES=(
26         "${FILESDIR}"/${P}-arrays.patch
27         "${FILESDIR}"/${P}-audio.patch
28         "${FILESDIR}"/${P}-speed.patch
29         "${FILESDIR}"/${P}-clang16.patch
32 src_compile() {
33         tc-export CC
35         append-cppflags $($(tc-getPKG_CONFIG) --cflags sdl SDL_mixer || die) \
36                 -DDATA_PREFIX="'\"${EPREFIX}/usr/share/${PN}/\"'" \
37                 -DENABLE_SOUND
38         append-libs $($(tc-getPKG_CONFIG) --libs sdl SDL_mixer || die)
40         emake main LDLIBS="${LIBS}"
43 src_install() {
44         newbin main ${PN}
46         insinto /usr/share/${PN}
47         doins -r gfx levels sounds
49         doicon "${DISTDIR}"/${PN}.png
50         make_desktop_entry ${PN} Convey
52         dodoc readme