1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit desktop toolchain-funcs
9 EXTRAS1="eboard-extras-1pl2"
10 EXTRAS2="eboard-extras-2"
11 DESCRIPTION="chess interface for POSIX systems"
12 HOMEPAGE="http://www.bergo.eng.br/eboard/"
13 SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.bz2
14 https://downloads.sourceforge.net/${PN}/${EXTRAS1}.tar.gz
15 https://downloads.sourceforge.net/${PN}/${EXTRAS2}.tar.gz
16 mirror://debian/pool/main/e/eboard/${PN}_${DEB_V}.diff.gz"
20 KEYWORDS="~amd64 ~arm64 ~x86"
26 dev-libs/gobject-introspection
43 "${WORKDIR}"/${PN}_${DEB_V}.diff
44 "${FILESDIR}"/${P}-as-needed.patch
45 "${FILESDIR}"/${P}-gcc44.patch
46 "${FILESDIR}"/${P}-ovflfix.patch
47 "${FILESDIR}"/${P}-libpng15.patch
54 -e "s:(\"-O6\"):split(' ', \"${CXXFLAGS}\"):" \
60 --compiler="$(tc-getCXX)" \
62 --data-prefix="/usr/share" \
63 --man-prefix="/usr/share/man" \
65 $(use_enable nls) || die # not an autoconf script
70 dodoc Documentation/*.txt
72 newicon icon-eboard.xpm ${PN}.xpm
73 make_desktop_entry ${PN} ${PN} ${PN}
75 cd "${WORKDIR}"/${EXTRAS1} || die
76 insinto /usr/share/${PN}
78 newins extras1.conf themeconf.extras1
79 newdoc ChangeLog Changelog.extras
80 newdoc README README.extras
83 cd "${WORKDIR}"/${EXTRAS2} || die
85 newins extras2.conf themeconf.extras2