app-shells/bash-completion: add 2.16.0
[gentoo/gentoo.git] / games-puzzle / numptyphysics / numptyphysics-9999.ebuild
blob738b4f6176371514e7f4e59e3863684232979afd
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit toolchain-funcs xdg
8 DESCRIPTION="Crayon Physics-like drawing puzzle game using the same excellent Box2D engine"
9 HOMEPAGE="https://github.com/thp/numptyphysics"
11 if [[ ${PV} == 9999 ]]; then
12         inherit git-r3
13         EGIT_REPO_URI="https://github.com/thp/numptyphysics.git"
14 else
15         SRC_URI="https://github.com/thp/numptyphysics/archive/${PV}.tar.gz -> ${P}.tar.gz"
16         KEYWORDS="~amd64"
19 LICENSE="BSD GPL-3+ ZLIB"
20 SLOT="0"
22 RDEPEND="
23         dev-libs/glib:2
24         media-libs/libsdl2[opengl,video]
25         media-libs/sdl2-image[png]
26         media-libs/sdl2-ttf
27         virtual/opengl"
28 DEPEND="${RDEPEND}"
29 BDEPEND="virtual/pkgconfig"
31 PATCHES=(
32         "${FILESDIR}"/${PN}-0.3.8-empty-tr.patch
33         "${FILESDIR}"/${PN}-0.3.8-respect-flags.patch
36 src_compile() {
37         tc-export AR CC CXX PKG_CONFIG RANLIB
39         emake V=1