1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 DESCRIPTION="Tcl/Tk variant of the well-known 15-puzzle game"
9 HOMEPAGE="https://www.naskita.com/linux/penguzzle/penguzzle.shtml"
10 SRC_URI="https://www.naskita.com/linux/${PN}/${PN}.zip -> ${P}.zip"
14 KEYWORDS="~amd64 ~x86"
19 BDEPEND="app-arch/unzip"
21 S="${WORKDIR}/${PN}${PV}"
26 -e "s:~/puzz/images:/usr/share/${PN}:" \
28 || die "sed init failed"
30 -e "s:~/puzz/lib:/usr/$(get_libdir)/${PN}:" \
32 || die "sed ${PN} failed"
34 eapply "${FILESDIR}"/${P}-tclx.patch
40 insinto /usr/share/${PN}
43 insinto /usr/$(get_libdir)/${PN}
46 newicon images/img0.gif ${PN}.gif
47 make_desktop_entry ${PN} "Penguzzle" /usr/share/pixmaps/${PN}.gif