app-shells/bash-completion: add 2.16.0
[gentoo/gentoo.git] / games-puzzle / penguzzle / penguzzle-1.0-r2.ebuild
blob691f9a2b3a163bba99fc60fd8579f1cbc5e2d0d7
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit desktop
8 DESCRIPTION="Tcl/Tk variant of the well-known 15-puzzle game"
9 HOMEPAGE="https://www.naskita.com/linux/penguzzle/penguzzle.shtml"
10 SRC_URI="https://www.naskita.com/linux/${PN}/${PN}.zip -> ${P}.zip"
12 LICENSE="penguzzle"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
16 RDEPEND="
17         dev-lang/tk:0=
18         dev-tcltk/tclx"
19 BDEPEND="app-arch/unzip"
21 S="${WORKDIR}/${PN}${PV}"
23 src_prepare() {
24         default
25         sed -i \
26                 -e "s:~/puzz/images:/usr/share/${PN}:" \
27                 lib/init \
28                 || die "sed init failed"
29         sed -i \
30                 -e "s:~/puzz/lib:/usr/$(get_libdir)/${PN}:" \
31                 bin/${PN} \
32                 || die "sed ${PN} failed"
34         eapply "${FILESDIR}"/${P}-tclx.patch
37 src_install() {
38         dobin bin/${PN}
40         insinto /usr/share/${PN}
41         doins images/img0.gif
43         insinto /usr/$(get_libdir)/${PN}
44         doins lib/init
46         newicon images/img0.gif ${PN}.gif
47         make_desktop_entry ${PN} "Penguzzle" /usr/share/pixmaps/${PN}.gif
49         einstalldocs