1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 CHECKREQS_DISK_BUILD="3G"
7 inherit check-reqs desktop wrapper xdg
10 DESCRIPTION="Skateboarding game where you play as a bird"
11 HOMEPAGE="https://glassbottommeg.itch.io/skatebird"
12 SRC_URI="skatebird-linux.zip"
14 LICENSE="all-rights-reserved"
17 RESTRICT="bindist fetch splitdebug"
25 QA_PREBUILT="${DIR#/}/*"
28 einfo "Please buy and download ${SRC_URI} from:"
30 einfo "and move it to your distfiles directory."
36 # Avoid error trying to create unity.lock.
37 sed -i "/^single-instance=/d" ${MY_PN}_Data/boot.config || die
42 newexe ${MY_PN}.x86_64 ${MY_PN}
46 doins -r ${MY_PN}_Data/
48 newicon -s 128 ${MY_PN}_Data/Resources/UnityPlayer.png ${PN}.png
49 make_wrapper ${PN} "${DIR}"/${MY_PN}
50 make_desktop_entry ${PN} ${MY_PN}