dev-vcs/breezy: drop 3.3.5-r1
[gentoo/gentoo.git] / games-sports / skatebird / skatebird-14.ebuild
blobfa99f085ac4aed56f3927aa8d394ff9669f34460
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 CHECKREQS_DISK_BUILD="3G"
7 inherit check-reqs desktop wrapper xdg
9 MY_PN="SkateBIRD"
10 DESCRIPTION="Skateboarding game where you play as a bird"
11 HOMEPAGE="https://glassbottommeg.itch.io/skatebird"
12 SRC_URI="skatebird-linux.zip"
14 LICENSE="all-rights-reserved"
15 SLOT="0"
16 KEYWORDS="-* ~amd64"
17 RESTRICT="bindist fetch splitdebug"
19 BDEPEND="
20         app-arch/unzip
23 S="${WORKDIR}"
24 DIR="/opt/${PN}"
25 QA_PREBUILT="${DIR#/}/*"
27 pkg_nofetch() {
28         einfo "Please buy and download ${SRC_URI} from:"
29         einfo "  ${HOMEPAGE}"
30         einfo "and move it to your distfiles directory."
33 src_prepare() {
34         default
36         # Avoid error trying to create unity.lock.
37         sed -i "/^single-instance=/d" ${MY_PN}_Data/boot.config || die
40 src_install() {
41         exeinto "${DIR}"
42         newexe ${MY_PN}.x86_64 ${MY_PN}
43         doexe UnityPlayer.so
45         insinto "${DIR}"
46         doins -r ${MY_PN}_Data/
48         newicon -s 128 ${MY_PN}_Data/Resources/UnityPlayer.png ${PN}.png
49         make_wrapper ${PN} "${DIR}"/${MY_PN}
50         make_desktop_entry ${PN} ${MY_PN}