1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
5 inherit java-pkg-opt-2 gnustep-2
8 DESCRIPTION="GNUstep lightweight database abstraction layer"
9 HOMEPAGE="http://wiki.gnustep.org/index.php/SQLClient"
10 SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${MY_P}.tar.gz"
12 KEYWORDS="~amd64 ~ppc ~x86"
16 IUSE="java mysql postgres +sqlite"
18 RDEPEND=">=gnustep-libs/performance-0.3.2
19 mysql? ( dev-db/mysql-connector-c:= )
20 postgres? ( dev-db/postgresql:= )
21 sqlite? ( >=dev-db/sqlite-3 )"
24 REQUIRED_USE="|| ( java mysql postgres sqlite )"
31 sed -i -e '/documentation\.make/d' GNUmakefile \
32 || die "doc sed failed"
40 use java || myconf="${myconf} --disable-jdbc-bundle"
41 use mysql || myconf="${myconf} --disable-mysql-bundle"
42 use postgres || myconf="${myconf} --disable-postgres-bundle"
43 use sqlite || myconf="${myconf} --disable-sqllite-bundle"