app-shells/bash-completion: add 2.16.0
[gentoo/gentoo.git] / gnustep-libs / sqlclient / sqlclient-1.9.0.ebuild
blob8f05cc06e501f80f5bb18e7fb342aff6e7bb9483
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 inherit java-pkg-opt-2 gnustep-2
7 MY_P=${P/sqlc/SQLC}
8 DESCRIPTION="GNUstep lightweight database abstraction layer"
9 HOMEPAGE="http://wiki.gnustep.org/index.php/SQLClient"
10 SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${MY_P}.tar.gz"
12 KEYWORDS="~amd64 ~ppc ~x86"
13 LICENSE="LGPL-3"
14 SLOT="0"
16 IUSE="java mysql postgres +sqlite"
18 RDEPEND=">=gnustep-libs/performance-0.3.2
19         mysql? ( dev-db/mysql-connector-c:= )
20         postgres? ( dev-db/postgresql:= )
21         sqlite? ( >=dev-db/sqlite-3 )"
22 DEPEND="${RDEPEND}"
24 REQUIRED_USE="|| ( java mysql postgres sqlite )"
26 S=${WORKDIR}/${MY_P}
28 src_prepare() {
29         if ! use doc; then
30                 # Remove doc target
31                 sed -i -e '/documentation\.make/d' GNUmakefile \
32                         || die "doc sed failed"
33         fi
35         default
38 src_configure() {
39         local myconf=""
40         use java || myconf="${myconf} --disable-jdbc-bundle"
41         use mysql || myconf="${myconf} --disable-mysql-bundle"
42         use postgres || myconf="${myconf} --disable-postgres-bundle"
43         use sqlite || myconf="${myconf} --disable-sqllite-bundle"
45         egnustep_env
46         econf ${myconf}