app-metrics/prometheus: add 3.1.0
[gentoo/gentoo.git] / gui-apps / railway / railway-2.7.2.ebuild
blob2ae8a45bd89e2bc5066f393d6607705f3c421eec
1 # Copyright 2024-2025 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 CRATES="
7         addr2line@0.22.0
8         adler@1.0.2
9         aho-corasick@1.1.3
10         android-tzdata@0.1.1
11         android_system_properties@0.1.5
12         anstream@0.6.14
13         anstyle-parse@0.2.4
14         anstyle-query@1.1.0
15         anstyle-wincon@3.0.3
16         anstyle@1.0.7
17         async-trait@0.1.78
18         atomic-waker@1.1.2
19         autocfg@1.3.0
20         backtrace@0.3.72
21         base64@0.22.1
22         bitflags@1.3.2
23         bitflags@2.6.0
24         block-buffer@0.10.4
25         block@0.1.6
26         bumpalo@3.16.0
27         bytes@1.5.0
28         cairo-rs@0.20.0
29         cairo-sys-rs@0.20.0
30         cc@1.1.6
31         cfg-expr@0.15.8
32         cfg-if@1.0.0
33         chrono-tz-build@0.2.1
34         chrono-tz@0.8.6
35         chrono@0.4.38
36         colorchoice@1.0.1
37         convert_case@0.6.0
38         core-foundation-sys@0.8.6
39         core-foundation@0.9.4
40         crypto-common@0.1.6
41         digest@0.10.7
42         displaydoc@0.2.5
43         encoding_rs@0.8.35
44         env_filter@0.1.0
45         env_logger@0.11.4
46         equivalent@1.0.1
47         errno@0.3.10
48         fastrand@2.2.0
49         field-offset@0.3.6
50         fnv@1.0.7
51         foreign-types-shared@0.1.1
52         foreign-types@0.3.2
53         form_urlencoded@1.2.1
54         futures-channel@0.3.30
55         futures-core@0.3.31
56         futures-executor@0.3.30
57         futures-io@0.3.30
58         futures-macro@0.3.31
59         futures-sink@0.3.31
60         futures-task@0.3.31
61         futures-util@0.3.31
62         gdk-pixbuf-sys@0.20.0
63         gdk-pixbuf@0.20.0
64         gdk4-sys@0.9.0
65         gdk4@0.9.0
66         generic-array@0.14.7
67         getrandom@0.2.12
68         gettext-rs@0.7.0
69         gettext-sys@0.21.3
70         gimli@0.29.0
71         gio-sys@0.20.0
72         gio@0.20.0
73         glib-macros@0.20.0
74         glib-sys@0.20.0
75         glib@0.20.0
76         gobject-sys@0.20.0
77         graphene-rs@0.20.0
78         graphene-sys@0.20.0
79         gsk4-sys@0.9.0
80         gsk4@0.9.0
81         gtk4-macros@0.9.0
82         gtk4-sys@0.9.0
83         gtk4@0.9.0
84         h2@0.4.7
85         hashbrown@0.14.5
86         heck@0.5.0
87         hermit-abi@0.3.9
88         hex@0.4.3
89         http-body-util@0.1.2
90         http-body@1.0.1
91         http@1.1.0
92         httparse@1.8.0
93         humantime@2.1.0
94         hyper-rustls@0.27.3
95         hyper-tls@0.6.0
96         hyper-util@0.1.7
97         hyper@1.5.1
98         iana-time-zone-haiku@0.1.2
99         iana-time-zone@0.1.60
100         icu_collections@1.5.0
101         icu_locid@1.5.0
102         icu_locid_transform@1.5.0
103         icu_locid_transform_data@1.5.0
104         icu_normalizer@1.5.0
105         icu_normalizer_data@1.5.0
106         icu_properties@1.5.1
107         icu_properties_data@1.5.0
108         icu_provider@1.5.0
109         icu_provider_macros@1.5.0
110         idna@1.0.3
111         idna_adapter@1.2.0
112         indexmap@2.2.6
113         ipnet@2.10.1
114         is_terminal_polyfill@1.70.0
115         itoa@1.0.11
116         js-sys@0.3.69
117         lazy_static@1.4.0
118         libadwaita-sys@0.7.0
119         libadwaita@0.7.0
120         libc@0.2.155
121         linux-raw-sys@0.4.14
122         litemap@0.7.4
123         locale_config@0.3.0
124         log@0.4.22
125         malloc_buf@0.0.6
126         md-5@0.10.6
127         memchr@2.7.4
128         memoffset@0.9.1
129         mime@0.3.17
130         miniz_oxide@0.7.4
131         mio@1.0.1
132         native-tls@0.2.12
133         num-traits@0.2.19
134         objc-foundation@0.1.1
135         objc@0.2.7
136         objc_id@0.1.1
137         object@0.35.0
138         once_cell@1.19.0
139         openssl-macros@0.1.1
140         openssl-probe@0.1.5
141         openssl-sys@0.9.104
142         openssl@0.10.68
143         pango-sys@0.20.0
144         pango@0.20.0
145         parse-zoneinfo@0.3.0
146         percent-encoding@2.3.1
147         phf@0.11.2
148         phf_codegen@0.11.2
149         phf_generator@0.11.2
150         phf_shared@0.11.2
151         pin-project-internal@1.1.7
152         pin-project-lite@0.2.14
153         pin-project@1.1.7
154         pin-utils@0.1.0
155         pkg-config@0.3.30
156         proc-macro-crate@3.1.0
157         proc-macro2@1.0.86
158         quote@1.0.36
159         railway-api-derive@0.1.1
160         railway-api@0.1.1
161         railway-core@0.1.1
162         railway-provider-db-movas@0.1.0
163         railway-provider-hafas@0.1.2
164         railway-provider-motis@0.1.0
165         railway-provider-search-ch@0.1.0
166         rand@0.8.5
167         rand_core@0.6.4
168         regex-automata@0.4.7
169         regex-syntax@0.8.4
170         regex@1.10.5
171         reqwest@0.12.5
172         ring@0.17.8
173         rustc-demangle@0.1.24
174         rustc_version@0.4.0
175         rustix@0.38.34
176         rustls-pemfile@2.1.2
177         rustls-pki-types@1.5.0
178         rustls-webpki@0.102.3
179         rustls@0.23.7
180         ryu@1.0.18
181         schannel@0.1.23
182         security-framework-sys@2.9.1
183         security-framework@2.9.2
184         semver@1.0.23
185         serde@1.0.204
186         serde_derive@1.0.204
187         serde_json@1.0.120
188         serde_spanned@0.6.6
189         serde_urlencoded@0.7.1
190         siphasher@0.3.11
191         slab@0.4.9
192         smallvec@1.13.2
193         socket2@0.5.7
194         spin@0.9.8
195         stable_deref_trait@1.2.0
196         subtle@2.6.1
197         syn@2.0.72
198         sync_wrapper@1.0.2
199         synstructure@0.13.1
200         system-configuration-sys@0.5.0
201         system-configuration@0.5.1
202         system-deps@7.0.1
203         target-lexicon@0.12.15
204         temp-dir@0.1.12
205         tempfile@3.11.0
206         thiserror-impl@1.0.63
207         thiserror@1.0.63
208         tinystr@0.7.6
209         tokio-macros@2.4.0
210         tokio-native-tls@0.3.1
211         tokio-rustls@0.26.0
212         tokio-util@0.7.12
213         tokio@1.39.1
214         toml@0.8.15
215         toml_datetime@0.6.6
216         toml_edit@0.21.1
217         toml_edit@0.22.16
218         tower-layer@0.3.3
219         tower-service@0.3.2
220         tower@0.4.13
221         tracing-core@0.1.32
222         tracing@0.1.40
223         try-lock@0.2.5
224         typenum@1.17.0
225         unicode-ident@1.0.12
226         unicode-segmentation@1.11.0
227         untrusted@0.9.0
228         url@2.5.4
229         utf16_iter@1.0.5
230         utf8_iter@1.0.4
231         utf8parse@0.2.2
232         uuid@1.12.0
233         vcpkg@0.2.15
234         version-compare@0.2.0
235         version_check@0.9.4
236         want@0.3.1
237         wasi@0.11.0+wasi-snapshot-preview1
238         wasm-bindgen-backend@0.2.92
239         wasm-bindgen-futures@0.4.42
240         wasm-bindgen-macro-support@0.2.92
241         wasm-bindgen-macro@0.2.92
242         wasm-bindgen-shared@0.2.92
243         wasm-bindgen@0.2.92
244         web-sys@0.3.69
245         winapi-i686-pc-windows-gnu@0.4.0
246         winapi-x86_64-pc-windows-gnu@0.4.0
247         winapi@0.3.9
248         windows-core@0.52.0
249         windows-sys@0.48.0
250         windows-sys@0.52.0
251         windows-targets@0.48.5
252         windows-targets@0.52.5
253         windows_aarch64_gnullvm@0.48.5
254         windows_aarch64_gnullvm@0.52.5
255         windows_aarch64_msvc@0.48.5
256         windows_aarch64_msvc@0.52.5
257         windows_i686_gnu@0.48.5
258         windows_i686_gnu@0.52.5
259         windows_i686_gnullvm@0.52.5
260         windows_i686_msvc@0.48.5
261         windows_i686_msvc@0.52.5
262         windows_x86_64_gnu@0.48.5
263         windows_x86_64_gnu@0.52.5
264         windows_x86_64_gnullvm@0.48.5
265         windows_x86_64_gnullvm@0.52.5
266         windows_x86_64_msvc@0.48.5
267         windows_x86_64_msvc@0.52.5
268         winnow@0.5.40
269         winnow@0.6.14
270         winreg@0.52.0
271         write16@1.0.0
272         writeable@0.5.5
273         yoke-derive@0.7.5
274         yoke@0.7.5
275         zerofrom-derive@0.1.5
276         zerofrom@0.1.5
277         zeroize@1.8.1
278         zerovec-derive@0.10.3
279         zerovec@0.10.4
282 inherit cargo gnome2-utils meson xdg-utils
284 DESCRIPTION="Travel with all your train information in one place"
285 HOMEPAGE="
286         https://mobile.schmidhuberj.de/railway/
287         https://gitlab.com/schmiddi-on-mobile/railway/
289 SRC_URI="
290         https://gitlab.com/schmiddi-on-mobile/railway/-/archive/${PV}/${P}.tar.bz2
291         ${CARGO_CRATE_URIS}
294 LICENSE="GPL-3+"
295 # Dependent crate licenses
296 LICENSE+="
297         Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD ISC MIT Unicode-3.0
298         Unicode-DFS-2016
299         || ( AGPL-3+ EUPL-1.2 )
301 # ring
302 LICENSE+=" openssl"
303 SLOT="0"
304 KEYWORDS="~amd64"
306 DEPEND="
307         >=dev-libs/glib-2.66
308         >=gui-libs/gtk-4.14:4
309         >=gui-libs/libadwaita-1.6.0
310         media-libs/graphene
312 RDEPEND="
313         ${DEPEND}
315 BDEPEND="
316         dev-libs/glib
317         dev-util/blueprint-compiler
318         sys-devel/gettext
321 BUILD_DIR=${S}/build
322 ECARGO_HOME=${BUILD_DIR}/cargo-home
324 QA_PREBUILT=usr/bin/diebahn
326 src_prepare() {
327         default
329         sed -e "s:get_option('profile.*:$(usex debug false true):" \
330                 -i src/meson.build || die
333 src_install() {
334         meson_src_install
335         dosym diebahn /usr/bin/railway
338 pkg_postinst() {
339         gnome2_schemas_update
340         xdg_icon_cache_update
343 pkg_postrm() {
344         gnome2_schemas_update
345         xdg_icon_cache_update