app-shells/bash-completion: add 2.16.0
[gentoo/gentoo.git] / gui-apps / wf-recorder / wf-recorder-0.3.0-r2.ebuild
blobfd58d11409c9c8da48a704964c45e52e974cfbb2
1 # Copyright 2020-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit meson
8 DESCRIPTION="Screen recorder for wlroots-based compositors"
9 HOMEPAGE="https://github.com/ammen99/wf-recorder"
11 if [[ ${PV} == *9999* ]]; then
12         inherit git-r3
13         EGIT_REPO_URI="https://github.com/ammen99/wf-recorder.git"
14 else
15         SRC_URI="https://github.com/ammen99/wf-recorder/releases/download/v${PV}/${P}.tar.xz"
16         KEYWORDS="~amd64 ~x86"
19 LICENSE="MIT"
20 SLOT="0"
22 DEPEND="
23         dev-libs/wayland
24         media-libs/libpulse
25         media-video/ffmpeg[pulseaudio,x264]
27 RDEPEND="${DEPEND}"
28 BDEPEND="
29         dev-libs/wayland-protocols
30         dev-util/wayland-scanner
31         virtual/pkgconfig