1 # Copyright 1999-2025 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 ECM_DESIGNERPLUGIN="true"
8 inherit ecm frameworks.kde.org
10 DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
12 LICENSE="LGPL-2+ LGPL-2.1+"
13 KEYWORDS="amd64 arm64 ppc64 ~riscv ~x86"
14 IUSE="aspell +hunspell qml"
17 >=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
18 aspell? ( app-text/aspell )
19 hunspell? ( app-text/hunspell:= )
20 qml? ( >=dev-qt/qtdeclarative-${QTMIN}:6 )
23 BDEPEND=">=dev-qt/qttools-${QTMIN}:6[linguist]"
27 sonnet-test_autodetect
30 sonnet-test_highlighter
35 $(cmake_use_find_package aspell ASPELL)
36 $(cmake_use_find_package hunspell HUNSPELL)
37 -DSONNET_USE_QML=$(usex qml)
39 if ! use aspell && ! use hunspell; then
40 mycmakeargs+=( -DSONNET_NO_BACKENDS=ON )