www-apache/mod_tls: new package, add 0.14.0
[gentoo/gentoo.git] / kde-frameworks / sonnet / sonnet-6.9.0.ebuild
blob9f18d62cd23bbb3bffcac18cbe67a53d1fc9ef25
1 # Copyright 1999-2025 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 ECM_DESIGNERPLUGIN="true"
7 QTMIN=6.7.2
8 inherit ecm frameworks.kde.org
10 DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
12 LICENSE="LGPL-2+ LGPL-2.1+"
13 KEYWORDS="amd64 arm64 ppc64 ~riscv ~x86"
14 IUSE="aspell +hunspell qml"
16 DEPEND="
17         >=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
18         aspell? ( app-text/aspell )
19         hunspell? ( app-text/hunspell:= )
20         qml? ( >=dev-qt/qtdeclarative-${QTMIN}:6 )
22 RDEPEND="${DEPEND}"
23 BDEPEND=">=dev-qt/qttools-${QTMIN}:6[linguist]"
25 CMAKE_SKIP_TESTS=(
26         # bug 779994
27         sonnet-test_autodetect
28         # bug 680032
29         sonnet-test_settings
30         sonnet-test_highlighter
33 src_configure() {
34         local mycmakeargs=(
35                 $(cmake_use_find_package aspell ASPELL)
36                 $(cmake_use_find_package hunspell HUNSPELL)
37                 -DSONNET_USE_QML=$(usex qml)
38         )
39         if ! use aspell && ! use hunspell; then
40                 mycmakeargs+=( -DSONNET_NO_BACKENDS=ON )
41         fi
43         ecm_src_configure