app-shells/bash-completion: add 2.16.0
[gentoo/gentoo.git] / kde-plasma / libkscreen / libkscreen-6.2.5.ebuild
blob60b44bc004218f51638da29f3f37bd274af12ee5
1 # Copyright 1999-2025 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 ECM_QTHELP="true"
7 ECM_TEST="forceoptional"
8 KFMIN=6.6.0
9 QTMIN=6.7.2
10 inherit ecm plasma.kde.org
12 DESCRIPTION="Plasma screen management library"
14 LICENSE="GPL-2" # TODO: CHECK
15 SLOT="6/8"
16 KEYWORDS="amd64 arm64 ~loong ~ppc64 ~riscv ~x86"
17 IUSE=""
19 # requires running session
20 RESTRICT="test"
22 # slot op: Uses Qt::GuiPrivate for qtx11extras_p.h
23 RDEPEND="
24         dev-libs/wayland
25         >=dev-qt/qtbase-${QTMIN}:6=[dbus,gui]
26         >=dev-qt/qtwayland-${QTMIN}:6
27         >=kde-frameworks/kconfig-${KFMIN}:6
28         x11-libs/libxcb:=
30 DEPEND="${RDEPEND}
31         >=dev-libs/plasma-wayland-protocols-1.14.0
33 BDEPEND="
34         >=dev-qt/qttools-${QTMIN}:6[linguist]
35         >=dev-qt/qtwayland-${QTMIN}:6
36         dev-util/wayland-scanner