dev-db/timescaledb: drop 2.16.1, 2.17.0, 2.17.1
[gentoo/gentoo.git] / lxqt-base / lxqt-config / lxqt-config-2.1.0.ebuild
blob0655cc3a16d334ebd4837a76c8d0ad6f29582201
1 # Copyright 1999-2025 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 MY_PV="$(ver_cut 1-2)"
8 inherit cmake xdg
10 DESCRIPTION="LXQt system configuration control center"
11 HOMEPAGE="https://lxqt-project.org/"
13 if [[ ${PV} == 9999 ]]; then
14         inherit git-r3
15         EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
16 else
17         SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
18         KEYWORDS="amd64 arm64 ~ppc64 ~riscv ~x86"
21 LICENSE="GPL-2 GPL-2+ GPL-3 LGPL-2 LGPL-2+ LGPL-2.1+ WTFPL-2"
22 SLOT="0"
23 IUSE="+monitor +touchpad"
25 BDEPEND="
26         >=dev-qt/qttools-6.6:6[linguist]
27         >=dev-util/lxqt-build-tools-2.1.0
29 DEPEND="
30         >=dev-libs/libqtxdg-4.1.0
31         >=dev-qt/qtbase-6.6:6[gui,widgets,xml]
32         >=dev-qt/qtsvg-6.6:6
33         =lxqt-base/liblxqt-${MY_PV}*:=
34         =lxqt-base/lxqt-menu-data-${MY_PV}*
35         sys-libs/zlib:=
36         x11-apps/setxkbmap
37         x11-libs/libxcb:=
38         x11-libs/libX11
39         x11-libs/libXcursor
40         x11-libs/libXfixes
41         monitor? ( kde-plasma/libkscreen:6= )
42         touchpad? (
43                 virtual/libudev:=
44                 x11-drivers/xf86-input-libinput
45                 x11-libs/libXi
46         )
48 RDEPEND="${DEPEND}"
50 src_configure() {
51         local mycmakeargs=(
52                 -DWITH_MONITOR=$(usex monitor)
53                 -DWITH_TOUCHPAD=$(usex touchpad)
54         )
56         cmake_src_configure
59 src_install() {
60         cmake_src_install
61         doman man/*.1 liblxqt-config-cursor/man/*.1 lxqt-config-appearance/man/*.1