1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
5 PYTHON_COMPAT=( python3_{10..12} )
7 inherit meson python-r1
9 DESCRIPTION="SDK for making video editors and more"
10 HOMEPAGE="http://wiki.pitivi.org/wiki/GES"
11 SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P/gstreamer/gst}.tar.xz"
12 S="${WORKDIR}"/${P/gstreamer/gst}
16 KEYWORDS="~amd64 ~arm64 ~x86"
18 IUSE="+introspection test"
19 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
20 # Some tests are failing
25 >=dev-libs/glib-2.40.0:2
27 >=media-libs/gstreamer-${PV}:1.0[introspection?]
28 >=media-libs/gst-plugins-base-${PV}:1.0[introspection?]
29 >=media-libs/gst-plugins-bad-${PV}:1.0[introspection?]
30 introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
33 BDEPEND="virtual/pkgconfig"
39 -Ddoc=disabled # hotdoc not packaged
40 $(meson_feature introspection)
41 $(meson_feature test tests)
42 -Dbash-completion=disabled
53 python_moduleinto gi.overrides
54 python_foreach_impl python_domodule bindings/python/gi/overrides/GES.py