media-gfx/photoqt: Stabilize 4.7-r1 amd64, #948000
[gentoo/gentoo.git] / media-libs / webrtc-audio-processing / webrtc-audio-processing-1.3-r2.ebuild
blobff62de9f7c0308a9deabe1f280d679223e06a325
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit meson-multilib
8 DESCRIPTION="AudioProcessing library from the webrtc.org codebase"
9 HOMEPAGE="https://www.freedesktop.org/software/pulseaudio/webrtc-audio-processing/"
10 SRC_URI="https://freedesktop.org/software/pulseaudio/${PN}/${P}.tar.xz"
12 LICENSE="BSD"
13 SLOT="1"
14 KEYWORDS="amd64 ~ppc64 ~x86 ~amd64-linux"
15 IUSE="cpu_flags_arm_neon"
17 RDEPEND="dev-cpp/abseil-cpp:=[${MULTILIB_USEDEP}]"
18 DEPEND="${RDEPEND}"
19 BDEPEND="virtual/pkgconfig"
21 PATCHES=(
22         "${FILESDIR}/${PN}-1.3-Add-generic-byte-order-and-pointer-size-detection.patch"
23         "${FILESDIR}/${PN}-1.3-big-endian-support.patch"
26 DOCS=( AUTHORS NEWS README.md )
28 multilib_src_configure() {
29         local emesonargs=(
30                 -Dneon=$(usex cpu_flags_arm_neon yes no)
31         )
32         meson_src_configure