1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 DESCRIPTION="AudioProcessing library from the webrtc.org codebase"
9 HOMEPAGE="https://www.freedesktop.org/software/pulseaudio/webrtc-audio-processing/"
10 SRC_URI="https://freedesktop.org/software/pulseaudio/${PN}/${P}.tar.xz"
14 KEYWORDS="amd64 ~ppc64 ~x86 ~amd64-linux"
15 IUSE="cpu_flags_arm_neon"
17 RDEPEND="dev-cpp/abseil-cpp:=[${MULTILIB_USEDEP}]"
19 BDEPEND="virtual/pkgconfig"
22 "${FILESDIR}/${PN}-1.3-Add-generic-byte-order-and-pointer-size-detection.patch"
23 "${FILESDIR}/${PN}-1.3-big-endian-support.patch"
26 DOCS=( AUTHORS NEWS README.md )
28 multilib_src_configure() {
30 -Dneon=$(usex cpu_flags_arm_neon yes no)