media-gfx/photoqt: Stabilize 4.7-r1 amd64, #948000
[gentoo/gentoo.git] / media-libs / woff2 / woff2-1.0.2-r5.ebuild
blob5fac984e13b330a4d36a64d892245327b4f29082
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake
8 DESCRIPTION="Encode/decode WOFF2 font format"
9 HOMEPAGE="https://github.com/google/woff2"
10 SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
15 IUSE=""
17 RDEPEND="app-arch/brotli:="
18 DEPEND="${RDEPEND}"
19 BDEPEND="virtual/pkgconfig"
21 src_configure() {
22         local mycmakeargs=(
23                 -DCMAKE_SKIP_RPATH=ON # needed, causes QA warnings otherwise
24                 -DCANONICAL_PREFIXES=ON #661942
25         )
26         cmake_src_configure
29 src_install() {
30         cmake_src_install
32         dobin "${BUILD_DIR}"/woff2_compress
33         dobin "${BUILD_DIR}"/woff2_decompress
34         dobin "${BUILD_DIR}"/woff2_info
36         einstalldocs