app-shells/bash-completion: add 2.16.0
[gentoo/gentoo.git] / media-plugins / kodi-peripheral-joystick / kodi-peripheral-joystick-9999.ebuild
blobeec5915d9a2c3e86744f99bbaf4101c94ba16c12
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit cmake kodi-addon
8 DESCRIPTION="Libretro compatibility layer for the Kodi Game API"
9 HOMEPAGE="https://github.com/xbmc/peripheral.joystick"
10 SRC_URI=""
12 case ${PV} in
13 9999)
14         SRC_URI=""
15         EGIT_BRANCH="Matrix"
16         EGIT_REPO_URI="https://github.com/xbmc/peripheral.joystick.git"
17         inherit git-r3
18         ;;
20         KEYWORDS="~amd64 ~x86"
21         CODENAME="Matrix"
22         SRC_URI="https://github.com/xbmc/peripheral.joystick/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
23         S="${WORKDIR}/peripheral.joystick-${PV}-${CODENAME}"
24         ;;
25 esac
27 LICENSE="GPL-2"
28 SLOT="0"
29 IUSE=""
31 DEPEND="
32         ~media-tv/kodi-9999
33         dev-libs/libpcre
34         dev-libs/tinyxml
35         "
36 RDEPEND="
37         ${DEPEND}
38         "