app-metrics/prometheus: add 3.1.0
[gentoo/gentoo.git] / media-plugins / vdr-joystick / vdr-joystick-0.0.3.ebuild
blobef59b287b173a471376f982dc15e79c762b023ec
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit vdr-plugin-2
8 DESCRIPTION="VDR plugin: allows using a joystick as a remote control for VDR"
9 HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
10 SRC_URI="http://vdr.websitec.de/download/${PN}/${P}.tgz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
16 DEPEND="media-video/vdr"
17 RDEPEND="${DEPEND}"
19 src_prepare() {
20         vdr-plugin-2_src_prepare
22         # do not call g++ directly, Bug #936467
23         sed -e 's| g++| $(CXX)|' -i Makefile || die
26 src_install() {
27         vdr-plugin-2_src_install
29         insinto /etc/vdr/plugins/joystick
30         doins   "${FILESDIR}"/mapping.conf
33 pkg_postinst() {
34         vdr-plugin-2_pkg_postinst
36         elog "To use the plugin your joystick has to be connected to your"
37         elog "game port and its kernel module has to be loaded."
38         elog "Check configuration file:"
39         elog "/etc/vdr/plugins/joystick/mapping.conf\n"