app-shells/bash-completion: add 2.16.0
[gentoo/gentoo.git] / net-proxy / nutcracker / nutcracker-0.4.1-r1.ebuild
blob3203b919e775285fb0f14208ac26aff825a998a2
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit autotools
8 DESCRIPTION="A fast, light-weight proxy for Memcached and Redis. (Twitter's Twemproxy)"
9 HOMEPAGE="https://github.com/twitter/twemproxy"
10 SRC_URI="https://github.com/twitter/twemproxy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11 S="${WORKDIR}/twemproxy-${PV}"
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="debug doc"
18 DEPEND=">=dev-libs/libyaml-0.1.4"
19 RDEPEND="${DEPEND}"
20 BDEPEND="virtual/pkgconfig"
22 PATCHES=(
23         # Let's use system libyaml
24         "${FILESDIR}"/${PN}-0.3.0-use-system-libyaml.patch
27 src_prepare() {
28         default
30         eautoreconf
33 src_configure() {
34         econf $(use debug)
37 src_install() {
38         default
40         insinto /etc/nutcracker
41         newins conf/nutcracker.yml nutcracker.yml.example
43         newconfd "${FILESDIR}/nutcracker.confd.2" nutcracker
44         newinitd "${FILESDIR}/nutcracker.initd.2" nutcracker
46         if use doc; then
47                 dodoc -r notes
48         fi