app-metrics/prometheus: add 3.1.0
[gentoo/gentoo.git] / sci-geosciences / pymap3d / pymap3d-3.0.1.ebuild
blob245a3ba6f72ab931780a1db64c0b29c741ae08de
1 # Copyright 2023-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 PYTHON_COMPAT=( python3_{10..13} )
6 DISTUTILS_USE_PEP517=setuptools
7 inherit distutils-r1
9 DESCRIPTION="Python 3-D coordinate conversions"
10 HOMEPAGE="https://github.com/geospace-code/pymap3d"
11 SRC_URI="https://github.com/geospace-code/${PN}/archive/refs/tags/v${PV}.tar.gz
12         -> ${P}.tar.gz"
14 LICENSE="BSD-2"
15 SLOT="0"
16 KEYWORDS="~amd64"
18 BDEPEND="test? (
19         dev-python/xarray
20         dev-python/pyproj
23 distutils_enable_tests pytest
25 src_prepare() {
26         rm src/pymap3d/tests/test_eci.py || die
27         default