1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 PYTHON_COMPAT=( python3_{9..12} )
10 DESCRIPTION="C++ library and tools for symbolic calculations"
11 HOMEPAGE="https://www.ginac.de/"
12 SRC_URI="http://www.ginac.de/${P}.tar.bz2"
16 KEYWORDS="amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
19 RDEPEND=">=sci-libs/cln-1.2.2"
26 dev-texlive/texlive-fontsrecommended
27 >=media-gfx/fig2dev-3.2.9-r3[ghostscript]
28 dev-texlive/texlive-latexextra
32 PATCHES=( "${FILESDIR}"/${PN}-1.8.2-pkgconfig.patch )
44 local -x VARTEXFONTS="${T}"/fonts
45 emake -C doc/reference html pdf
46 emake -C doc/tutorial ginac.pdf ginac.html
54 pushd doc >/dev/null || die
55 newdoc tutorial/ginac.pdf tutorial.pdf
56 newdoc reference/reference.pdf reference.pdf
58 docinto html/reference
59 dodoc -r reference/html_files/.
62 newdoc tutorial/ginac.html tutorial.html
63 popd >/dev/null || die
67 pushd doc >/dev/null || die
69 dodoc examples/*.cpp examples/ginac-examples.*
70 docompress -x /usr/share/doc/${PF}/examples
71 popd >/dev/null || die
75 find "${ED}" -name '*.la' -delete || die