1 # Copyright 1999-2025 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 # Sphinx doc building is not compatible with in-tree version of sphinx-bibtex:
7 # Extension error: You must configure the bibtex_bibfiles setting
9 # PYTHON_COMPAT=( python3_{8..10} )
10 # DOCS_BUILDER="sphinx"
12 # dev-python/sphinxcontrib-bibtex
13 # dev-python/sphinx-rtd-theme
16 inherit cmake xdg # python-any-r1 docs
18 DESCRIPTION="General purpose computer algebra system"
19 HOMEPAGE="https://www.yacas.org/"
20 SRC_URI="https://github.com/grzegorzmazur/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
24 KEYWORDS="~amd64 ~x86"
26 RESTRICT="!test? ( test )"
28 # Upstream bundles MathJax-2.x
36 >=net-libs/zmqpp-4.1.2
42 # TODO: Unbundle CodeMirror
44 -DENABLE_CYACAS_BENCHMARKS=OFF
46 # -DENABLE_DOCS=$(usex doc)
47 -DENABLE_JYACAS=OFF # requires manual install
48 -DENABLE_CYACAS_GUI=OFF # bug 926677
49 # use system version of mathjax instead
50 -DENABLE_CYACAS_GUI_PRIVATE_MATHJAX=OFF
51 -DMATHJAX_PATH="${EPREFIX}/usr/share/mathjax/MathJax.js"
52 -DENABLE_CYACAS_KERNEL=$(usex jupyter)
53 -DENABLE_CYACAS_UNIT_TESTS=$(usex test)