app-shells/bash-completion: add 2.16.0
[gentoo/gentoo.git] / sys-auth / ykpers / ykpers-1.20.0-r1.ebuild
bloba6c1aeee4cbe03e166e8c1a57021fe8f2413af19
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit autotools udev
8 MY_PN="yubikey-personalization"
10 DESCRIPTION="Library and tool for personalization of Yubico's YubiKey"
11 HOMEPAGE="https://github.com/Yubico/yubikey-personalization"
12 SRC_URI="https://github.com/Yubico/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
14 LICENSE="BSD-2"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
18 RDEPEND="dev-libs/json-c:=
19         >=sys-auth/libyubikey-1.6
20         virtual/libusb:1"
21 DEPEND="${RDEPEND}"
22 BDEPEND="app-text/asciidoc
23         virtual/pkgconfig"
25 PATCHES=(
26         "${FILESDIR}"/${PN}-1.20.0-fix-gcc10-fno-common.patch
27         "${FILESDIR}"/${PN}-1.20.0-json-boolean.patch
30 DOCS=( doc/. AUTHORS NEWS README )
32 S="${WORKDIR}/${MY_PN}-${PV}"
34 src_prepare() {
35         default
36         eautoreconf
39 src_configure() {
40         local myeconfargs=(
41                 --libdir=/usr/$(get_libdir)
42                 --localstatedir=/var
43         )
44         econf "${myeconfargs[@]}"
47 src_install() {
48         default
50         udev_dorules 69-yubikey.rules
52         find "${D}" -name '*.la' -delete || die
55 pkg_postinst() {
56         udev_reload
59 pkg_postrm() {
60         udev_reload