app-shells/bash-completion: add 2.16.0
[gentoo/gentoo.git] / sys-power / acpi_call / acpi_call-1.2.2-r1.ebuild
blobb7fd9601068a49b68e69d09bcbe3f165c36583bd
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit linux-mod-r1
8 DESCRIPTION="A linux kernel module that enables calls to ACPI"
9 HOMEPAGE="https://github.com/nix-community/acpi_call"
10 SRC_URI="https://github.com/nix-community/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="GPL-3+"
13 SLOT="0"
14 KEYWORDS="amd64"
15 IUSE="examples"
17 CONFIG_CHECK="ACPI"
19 src_compile() {
20         local modargs=( KDIR=${KV_OUT_DIR} )
21         local modlist=( acpi_call=misc )
23         linux-mod-r1_src_compile
26 src_install() {
27         linux-mod-r1_src_install
29         if use examples; then
30                 insinto /usr/share/acpi_call
31                 doins examples/*.sh
32         fi