app-metrics/prometheus: add 3.1.0
[gentoo/gentoo.git] / virtual / rust / rust-1.75.0-r1.ebuild
blob4e9f43e5561b311f64286a28f51f1061def9bf21
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit multilib-build
8 DESCRIPTION="Virtual for Rust language compiler"
10 LICENSE=""
12 # adjust when rust upstream bumps internal llvm
13 # we do not allow multiple llvm versions in dev-lang/rust for
14 # neither system nor bundled, so we just hardcode it here.
15 SLOT="0/llvm-17"
16 KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
17 IUSE="profiler rustfmt"
19 BDEPEND=""
20 RDEPEND="|| (
21         ~dev-lang/rust-bin-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
22         ~dev-lang/rust-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]