app-metrics/prometheus: add 3.1.0
[gentoo/gentoo.git] / virtual / rust / rust-1.82.0.ebuild
blob2f9c39eae887e9b61d1106e7bf6737fffce28444
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit multilib-build
8 DESCRIPTION="Virtual for Rust language compiler"
10 # adjust when rust upstream bumps internal llvm
11 # we do not allow multiple llvm versions in dev-lang/rust for
12 # neither system nor bundled, so we just hardcode it here.
13 SLOT="0/llvm-19"
14 KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
15 IUSE="rustfmt profiler"
17 RDEPEND="|| (
18         ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
19         ~dev-lang/rust-${PV}[profiler?,rustfmt?,${MULTILIB_USEDEP}]