media-gfx/photoqt: Stabilize 4.7-r1 amd64, #948000
[gentoo/gentoo.git] / x11-misc / screen-message / screen-message-0.26.ebuild
bloba68ba782d88092517c0c1d84f3d453260259428f
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI="7"
6 inherit xdg
8 DESCRIPTION="Display a multi-line message large, fullscreen, black on white"
9 HOMEPAGE="http://www.joachim-breitner.de/projects#screen-message"
10 SRC_URI="mirror://debian/pool/main/s/${PN}/${PN}_${PV}.orig.tar.gz"
12 LICENSE="GPL-2+"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
17 DEPEND="x11-libs/gtk+:3
18         x11-libs/cairo
19         >=x11-libs/pango-1.16"
20 RDEPEND="${DEPEND}"
22 src_install() {
23         default
25         # It's not a game so let's make it *not* end up /usr/games
26         dodir /usr/bin
27         mv "${D}"/usr/{games,bin}/sm || die
28         rmdir "${D}"/usr/games || die
29         sed 's|^Exec=/usr/games/sm|Exec=/usr/bin/sm|' \
30                 -i "${D}"/usr/share/applications/sm.desktop || die