1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit toolchain-funcs
10 DESCRIPTION="A general-purpose fuzzer"
11 HOMEPAGE="https://gitlab.com/akihe/radamsa"
13 https://gitlab.com/akihe/${PN}/-/archive/v${PV}/${MY_P}.tar.bz2
14 https://gitlab.com/akihe/${PN}/uploads/d774a42f7893012d0a56c490a75ae12b/${P}.c.gz
19 KEYWORDS="~amd64 ~x86"
25 "${FILESDIR}"/${PN}-0.7_prebuilt-c.patch
28 S="${WORKDIR}"/${MY_P}
33 cp "${WORKDIR}"/${P}.c "${S}"/${PN}.c || die
37 emake bin/radamsa CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
42 # avoid man compression by build system