app-admin/awscli: Bump to 1.37.9
[gentoo/gentoo.git] / dev-erlang / jose / jose-1.11.10.ebuild
blob96dd36892e527bf6b592e4f78d4a8af42c8c9069
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit rebar
8 DESCRIPTION="JSON Object Signing and Encryption (JOSE) for Erlang and Elixir"
9 HOMEPAGE="https://github.com/potatosalad/erlang-jose"
10 SRC_URI="
11         https://github.com/potatosalad/erlang-jose/archive/${PV}.tar.gz
12                 -> erlang-${P}.tar.gz
15 S="${WORKDIR}/erlang-${P}"
17 LICENSE="MIT"
18 SLOT="0"
19 KEYWORDS="amd64 ~arm ~sparc ~x86"
21 DEPEND=">=dev-lang/erlang-19.0"
22 RDEPEND="${DEPEND}"
24 DOCS=( ALGORITHMS.md CHANGELOG.md README.md examples/KEY-GENERATION.md )
26 # TODO: jose has test suite, but it require lots of dependencies. It may not be
27 # TODO: urgent, but it would be nice to have those sooner or later.
28 RESTRICT=test