app-admin/awscli: Bump to 1.37.9
[gentoo/gentoo.git] / games-action / descent1-demodata / descent1-demodata-1.4-r1.ebuild
blobe24d037ae4bb67d60b2cf046a3a11768bcbce410
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit unpacker
8 DEMO="desc${PV//.}sw.exe"
10 DESCRIPTION="Demo data files for Descent 1"
11 HOMEPAGE="https://www.interplay.com"
12 SRC_URI="https://icculus.org/d2x/data/${DEMO}
13         ftp://ftp.funet.fi/pub/msdos/games/interplay/${DEMO}"
14 LICENSE="free-noncomm"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
18 RDEPEND="!games-action/descent1-data"
20 BDEPEND="app-arch/unzip
21         app-arch/arj"
23 S="${WORKDIR}"
25 src_unpack() {
26         unpack_zip ${A}
28         mv DESCENT2.SOW DESCENT1.S01 || die
29         arj e -v -y -_ DESCENT1.SOW || die
32 src_install() {
33         insinto /usr/share/games/d1x
34         doins descent.{hog,pig}
35         dodoc *.txt
38 pkg_postinst() {
39         elog "A client is needed to run the game, e.g. games-action/dxx-rebirth."
40         echo