1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit cdrom desktop wrapper
8 DESCRIPTION="3D third-person action shooter based on the Heavy Metal comics/movies"
9 HOMEPAGE="http://www.lokigames.com/products/fakk2/"
17 RESTRICT="strip bindist"
19 RDEPEND="virtual/opengl"
26 ewarn "The installed game takes about 378MB of space!"
32 einfo "Copying files... this may take a while..."
34 doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/${PN}
36 doins ${CDROM_ROOT}/{README,icon.{bmp,xpm}}
38 doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/fakk/{c,f}game.so
41 doins ${CDROM_ROOT}/fakk/pak{0,1,2,3}.pk3
42 doins ${CDROM_ROOT}/fakk/default.cfg
45 # Now, since these files are coming off a cd, the times/sizes/md5sums won't
46 # be different ... that means portage will try to unmerge some files (!)
47 # So, we run touch on ${D} to make sure portage doesn't do any such thing
48 find "${Ddir}" -exec touch '{}' \; || die
50 make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
51 newicon ${CDROM_ROOT}/icon.xpm ${PN}.xpm
53 make_desktop_entry ${PN} "FAKK2" ${PN}
58 ewarn "There are two possible security bugs in this package, both causing a denial of"
59 ewarn "service. One affects the game when running a server, the other when running as"
60 ewarn "a client. For more information, see bug #82149."
62 elog "To play the game run:"