app-admin/awscli: Bump to 1.37.9
[gentoo/gentoo.git] / games-board / xmahjongg / xmahjongg-3.7-r2.ebuild
blobc4ba67f96136e4966c2567fc62e8250d8fec5639
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit autotools desktop
8 DESCRIPTION="Friendly GUI version of xmahjongg"
9 HOMEPAGE="https://www.lcdf.org/xmahjongg/"
10 SRC_URI="https://www.lcdf.org/xmahjongg/${P}.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~mips ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
16 RDEPEND="x11-libs/libX11"
17 DEPEND="${RDEPEND}
18         x11-libs/libXt"
20 PATCHES=(
21         "${FILESDIR}"/${P}-autotools.patch
22         "${FILESDIR}"/${P}-drop-register-keyword.patch
25 src_prepare() {
26         default
27         mv configure.{in,ac} || die
28         eautoreconf
31 src_install() {
32         default
34         newicon share/tiles/small.gif ${PN}.gif
35         make_desktop_entry xmahjongg "Xmahjongg" /usr/share/pixmaps/${PN}.gif