app-admin/awscli: Bump to 1.37.9
[gentoo/gentoo.git] / media-libs / freeverb3 / freeverb3-3.2.1-r3.ebuild
blob7ce58affde0600f148ab025b2118a29e293bb9a0
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DESCRIPTION="Reverb and Impulse Response Convolution plug-ins (Audacious/JACK)"
7 HOMEPAGE="https://savannah.nongnu.org/projects/freeverb3"
8 SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz"
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="amd64 x86"
13 IUSE="forcefpu openmp plugdouble threads"
15 RDEPEND="sci-libs/fftw:3.0="
16 DEPEND="${RDEPEND}"
18 src_configure() {
19         local myeconfargs=(
20                 --enable-release
21                 --enable-undenormal
22                 --disable-autocflags
23                 --disable-pluginit
24                 --disable-profile
25                 --disable-sample
26                 --disable-srcnewcoeffs
27                 --disable-audacious
28                 --disable-jack
29                 $(use_enable openmp omp)
30                 $(use_enable plugdouble)
31                 $(use_enable threads pthread)
32         )
33         econf "${myeconfargs[@]}"
36 src_install() {
37         emake DESTDIR="${D}" install
38         einstalldocs
40         insinto /usr/share/${PN}/samples/IR
41         doins samples/IR/*.wav
43         find "${D}" -name '*.la' -delete || die  # bug 847403