1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 DESCRIPTION="Reverb and Impulse Response Convolution plug-ins (Audacious/JACK)"
7 HOMEPAGE="https://savannah.nongnu.org/projects/freeverb3"
8 SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz"
13 IUSE="forcefpu openmp plugdouble threads"
15 RDEPEND="sci-libs/fftw:3.0="
26 --disable-srcnewcoeffs
29 $(use_enable openmp omp)
30 $(use_enable plugdouble)
31 $(use_enable threads pthread)
33 econf "${myeconfargs[@]}"
37 emake DESTDIR="${D}" install
40 insinto /usr/share/${PN}/samples/IR
41 doins samples/IR/*.wav
43 find "${D}" -name '*.la' -delete || die # bug 847403