1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit gstreamer-meson
8 DESCRIPTION="A GStreamer based RTSP server"
9 HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-rtsp-server.html"
12 KEYWORDS="amd64 ~arm64 x86"
13 IUSE="examples +introspection static-libs"
15 # gst-plugins-base for many used elements and API
16 # gst-plugins-good for rtprtxsend and rtpbin elements, maybe more
17 # gst-plugins-srtp for srtpenc and srtpdec elements
19 >=media-libs/gstreamer-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
20 >=media-libs/gst-plugins-base-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
21 >=media-libs/gst-plugins-good-${PV}:${SLOT}[${MULTILIB_USEDEP}]
22 >=media-plugins/gst-plugins-srtp-${PV}:${SLOT}[${MULTILIB_USEDEP}]
23 introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
28 multilib_src_configure() {
30 -Dintrospection=$(multilib_native_usex introspection enabled disabled)
33 gstreamer_multilib_src_configure
36 multilib_src_install_all() {
39 if use examples ; then
41 dodoc "${S}"/examples/*.c