app-admin/awscli: Bump to 1.37.9
[gentoo/gentoo.git] / media-libs / gst-rtsp-server / gst-rtsp-server-1.22.11.ebuild
bloba01c6cb7a95f98efd7ac9b95ab99daedd2d0a27f
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit gstreamer-meson
8 DESCRIPTION="A GStreamer based RTSP server"
9 HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-rtsp-server.html"
11 LICENSE="LGPL-2+"
12 KEYWORDS="amd64 ~arm64 x86"
13 IUSE="examples +introspection static-libs"
15 # gst-plugins-base for many used elements and API
16 # gst-plugins-good for rtprtxsend and rtpbin elements, maybe more
17 # gst-plugins-srtp for srtpenc and srtpdec elements
18 RDEPEND="
19         >=media-libs/gstreamer-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
20         >=media-libs/gst-plugins-base-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
21         >=media-libs/gst-plugins-good-${PV}:${SLOT}[${MULTILIB_USEDEP}]
22         >=media-plugins/gst-plugins-srtp-${PV}:${SLOT}[${MULTILIB_USEDEP}]
23         introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
25 DEPEND="${RDEPEND}"
26 BDEPEND=""
28 multilib_src_configure() {
29         local emesonargs=(
30                 -Dintrospection=$(multilib_native_usex introspection enabled disabled)
31         )
33         gstreamer_multilib_src_configure
36 multilib_src_install_all() {
37         einstalldocs
39         if use examples ; then
40                 docinto examples
41                 dodoc "${S}"/examples/*.c
42         fi