1 # Copyright 1999-2025 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 if [[ ${PV} == *9999* ]]; then
9 EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libvisio.git"
10 inherit autotools git-r3
12 SRC_URI="https://dev-www.libreoffice.org/src/libvisio/${P}.tar.xz"
13 KEYWORDS="amd64 ~arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~sparc x86"
16 DESCRIPTION="Library parsing the file format of MS Visio documents"
17 HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libvisio"
19 LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
22 RESTRICT="!test? ( test )"
33 test? ( dev-util/cppunit )
38 doc? ( app-text/doxygen )
43 [[ -d m4 ]] || mkdir "m4" || die
44 [[ ${PV} == *9999* ]] && eautoreconf
49 append-cxxflags -std=c++17
53 $(use_enable test tests)
56 econf "${myeconfargs[@]}"
61 find "${ED}" -name '*.la' -delete || die