app-admin/awscli: Bump to 1.37.9
[gentoo/gentoo.git] / media-libs / libvisio / libvisio-0.1.8.ebuild
blob57de08828523b8dfb55bc9303f3ff381d71f84d5
1 # Copyright 1999-2025 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit flag-o-matic
8 if [[ ${PV} == *9999* ]]; then
9         EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libvisio.git"
10         inherit autotools git-r3
11 else
12         SRC_URI="https://dev-www.libreoffice.org/src/libvisio/${P}.tar.xz"
13         KEYWORDS="amd64 ~arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~sparc x86"
16 DESCRIPTION="Library parsing the file format of MS Visio documents"
17 HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libvisio"
19 LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
20 SLOT="0"
21 IUSE="doc test tools"
22 RESTRICT="!test? ( test )"
24 RDEPEND="
25         dev-libs/icu:=
26         dev-libs/librevenge
27         dev-libs/libxml2
29 DEPEND="${RDEPEND}
30         dev-libs/boost
31         dev-util/gperf
32         dev-build/libtool
33         test? ( dev-util/cppunit )
35 BDEPEND="
36         dev-lang/perl
37         virtual/pkgconfig
38         doc? ( app-text/doxygen )
41 src_prepare() {
42         default
43         [[ -d m4 ]] || mkdir "m4" || die
44         [[ ${PV} == *9999* ]] && eautoreconf
47 src_configure() {
48         # bug 619688, 932496
49         append-cxxflags -std=c++17
51         local myeconfargs=(
52                 $(use_with doc docs)
53                 $(use_enable test tests)
54                 $(use_enable tools)
55         )
56         econf "${myeconfargs[@]}"
59 src_install() {
60         default
61         find "${ED}" -name '*.la' -delete || die