app-admin/awscli: Bump to 1.37.9
[gentoo/gentoo.git] / media-libs / plib / plib-1.8.5-r4.ebuild
blobb5769bd1ab111b70cc91e73e909fb8a50a29d2dc
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit autotools flag-o-matic
8 DESCRIPTION="Multimedia library used by many games"
9 HOMEPAGE="https://plib.sourceforge.net/"
10 SRC_URI="https://plib.sourceforge.net/dist/${P}.tar.gz"
12 LICENSE="LGPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 ~hppa ppc sparc x86"
16 DEPEND="virtual/opengl"
17 RDEPEND="${DEPEND}"
19 PATCHES=(
20         "${FILESDIR}"/${P}-shared-libs.patch
21         "${FILESDIR}"/${P}-X11-r1.patch
22         "${FILESDIR}"/${P}-CVE-2011-4620.patch
23         "${FILESDIR}"/${P}-CVE-2012-4552.patch
26 src_prepare() {
27         default
29         eautoreconf
32 src_configure() {
33         append-cxxflags -std=c++03
35         # violates strict aliasing rules and is LTO-unsafe: https://bugs.gentoo.org/860048
36         # Per upstream in 2021, "PLIB has been obsolete and unmaintained for at LEAST 15 years!!"
37         # so this is getting fixed exactly never and getting worse.
38         append-cxxflags -fno-strict-aliasing
39         filter-lto
41         local myconf=(
42                 --enable-shared
43         )
45         econf "${myconf[@]}"
48 src_install() {
49         default
51         dodoc KNOWN_BUGS TODO* NOTICE
53         find "${ED}" -name '*.la' -delete || die