app-admin/awscli: Bump to 1.37.9
[gentoo/gentoo.git] / media-libs / webrtc-audio-processing / webrtc-audio-processing-0.3.1.ebuild
bloba80b092ee24a613efe7892bd63d7a4ed8d4743ab
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit autotools multilib-minimal
8 DESCRIPTION="AudioProcessing library from the webrtc.org code base"
9 HOMEPAGE="https://www.freedesktop.org/software/pulseaudio/webrtc-audio-processing/"
10 SRC_URI="https://freedesktop.org/software/pulseaudio/${PN}/${P}.tar.xz"
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm64 x86 ~amd64-linux"
15 IUSE="static-libs"
17 DOCS=( AUTHORS NEWS README.md )
19 PATCHES=(
20         "${FILESDIR}"/${PN}-0.3-proper_detection_cxxabi_execinfo.patch
23 src_prepare() {
24         eautoreconf
25         default
28 multilib_src_configure() {
29         ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
32 multilib_src_install_all() {
33         find "${ED}" -type f -name "*.la" -delete || die