1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit autotools multilib-minimal
8 DESCRIPTION="AudioProcessing library from the webrtc.org code base"
9 HOMEPAGE="https://www.freedesktop.org/software/pulseaudio/webrtc-audio-processing/"
10 SRC_URI="https://freedesktop.org/software/pulseaudio/${PN}/${P}.tar.xz"
14 KEYWORDS="amd64 ~arm64 x86 ~amd64-linux"
17 DOCS=( AUTHORS NEWS README.md )
20 "${FILESDIR}"/${PN}-0.3-proper_detection_cxxabi_execinfo.patch
28 multilib_src_configure() {
29 ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
32 multilib_src_install_all() {
33 find "${ED}" -type f -name "*.la" -delete || die