app-admin/awscli: Bump to 1.37.9
[gentoo/gentoo.git] / media-libs / webrtc-audio-processing / webrtc-audio-processing-1.3-r3.ebuild
blob112b1203df41db0cbfd22daaa1c55f6a65220940
1 # Copyright 1999-2025 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit meson-multilib
8 DESCRIPTION="AudioProcessing library from the webrtc.org codebase"
9 HOMEPAGE="https://www.freedesktop.org/software/pulseaudio/webrtc-audio-processing/"
10 SRC_URI="https://freedesktop.org/software/pulseaudio/${PN}/${P}.tar.xz"
12 LICENSE="BSD"
13 SLOT="1"
14 KEYWORDS="amd64 ~arm64 ~ppc64 x86 ~amd64-linux"
15 IUSE="cpu_flags_arm_neon"
17 RDEPEND="dev-cpp/abseil-cpp:=[${MULTILIB_USEDEP}]"
18 DEPEND="${RDEPEND}"
19 BDEPEND="virtual/pkgconfig"
21 PATCHES=(
22         "${FILESDIR}/${PN}-1.3-Add-generic-byte-order-and-pointer-size-detection.patch"
23         "${FILESDIR}/${PN}-1.3-big-endian-support.patch"
24         "${FILESDIR}/${PN}-1.3-x86-no-sse.patch"
25         "${FILESDIR}/${PN}-1.3-musl.patch"
26         "${FILESDIR}/${PN}-1.3-gcc15-cstdint.patch"
29 DOCS=( AUTHORS NEWS README.md )
31 multilib_src_configure() {
32         if [[ ${ABI} == x86 ]] ; then
33                 # bug #921140
34                 local -x CPPFLAGS="${CPPFLAGS} -DPFFFT_SIMD_DISABLE"
35         fi
37         local emesonargs=(
38                 -Dneon=$(usex cpu_flags_arm_neon yes no)
39         )
40         meson_src_configure