1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit toolchain-funcs
10 DESCRIPTION="Internet bandwidth tester"
11 HOMEPAGE="https://tptest.sourceforge.net/"
12 SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
16 KEYWORDS="amd64 ppc sparc x86"
19 "${FILESDIR}"/${PN}-3.1.7-getstatsfromlinevuln.patch
20 "${FILESDIR}"/${PN}-3.1.7-clang16-build-fix.patch
26 sed -i apps/unix/{client,server}/Makefile \
27 -e "s:^CFLAGS[[:space:]]*=:CFLAGS+=:" \
30 cp -f os-dep/unix/* . || die
31 cp -f engine/* . || die
35 emake -C apps/unix/client \
39 emake -C apps/unix/server \
45 dobin apps/unix/client/tptestclient
46 dosbin apps/unix/server/tptestserver
49 doins apps/unix/server/tptest.conf