app-admin/awscli: Bump to 1.37.9
[gentoo/gentoo.git] / net-analyzer / tptest / tptest-3.1.7-r3.ebuild
blobb1331c02ae928baeabb9732691332685dd4fee5e
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit toolchain-funcs
8 MY_PV="${PV/./_}"
10 DESCRIPTION="Internet bandwidth tester"
11 HOMEPAGE="https://tptest.sourceforge.net/"
12 SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 ppc sparc x86"
18 PATCHES=(
19         "${FILESDIR}"/${PN}-3.1.7-getstatsfromlinevuln.patch
20         "${FILESDIR}"/${PN}-3.1.7-clang16-build-fix.patch
23 src_prepare() {
24         default
26         sed -i apps/unix/{client,server}/Makefile \
27                 -e "s:^CFLAGS[[:space:]]*=:CFLAGS+=:" \
28                 || die
30         cp -f os-dep/unix/* . || die
31         cp -f engine/* . || die
34 src_compile() {
35         emake -C apps/unix/client \
36                 CC="$(tc-getCC)" \
37                 LDFLAGS="${LDFLAGS}"
39         emake -C apps/unix/server \
40                 CC="$(tc-getCC)" \
41                 LDFLAGS="${LDFLAGS}"
44 src_install() {
45         dobin apps/unix/client/tptestclient
46         dosbin apps/unix/server/tptestserver
48         insinto /etc
49         doins apps/unix/server/tptest.conf