app-admin/awscli: Bump to 1.37.9
[gentoo/gentoo.git] / net-dialup / freeradius-client / freeradius-client-1.1.7-r3.ebuild
blobb57e9ff96cd862ca49a0383208d0cc3f9a027c16
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit autotools flag-o-matic
8 DESCRIPTION="FreeRADIUS Client framework"
9 HOMEPAGE="https://wiki.freeradius.org/project/Radiusclient"
10 SRC_URI="ftp://ftp.freeradius.org/pub/freeradius/${P}.tar.gz"
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm arm64 ~hppa ppc ppc64 ~riscv sparc x86"
16 IUSE="scp shadow static-libs"
18 DEPEND="
19         !net-dialup/radiusclient-ng
20         virtual/libcrypt:=
22 RDEPEND="${DEPEND}"
24 DOCS=(
25         BUGS doc/{ChangeLog,login.example,release-method.txt,instop.html}
26         README.{radexample,rst}
29 PATCHES=(
30         "${FILESDIR}/${PN}-1.1.7-ar-configure.in.patch"
31         "${FILESDIR}/${PN}-1.1.7-configure-clang16.patch"
34 src_prepare() {
35         default
36         mv configure.in configure.ac || die \
37                 "Renaming configure.in to configure.ac failed"
39         eautoreconf
42 src_configure() {
43         # -Werror=lto-type-mismatch
44         # https://bugs.gentoo.org/927175
45         # https://github.com/FreeRADIUS/freeradius-client/issues/128
46         filter-lto
48         local myeconfargs=(
49                 $(use_enable scp)
50                 $(use_enable shadow)
51                 --with-secure-path
52         )
53         econf "${myeconfargs[@]}"
56 src_install() {
57         default
58         newdoc doc/README README.login.example
60         use static-libs || \
61                 find "${ED}" -name '*.a' -delete