app-admin/awscli: Bump to 1.37.9
[gentoo/gentoo.git] / sys-block / dust / dust-1.1.1-r1.ebuild
blob1fe5137f1cc4e2832482a537bd82b7bba91aa479
1 # Copyright 2023-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.3
6 EAPI=8
8 CRATES="
9         aho-corasick@1.1.3
10         android-tzdata@0.1.1
11         android_system_properties@0.1.5
12         ansi_term@0.12.1
13         anstream@0.6.13
14         anstyle-parse@0.2.3
15         anstyle-query@1.0.2
16         anstyle-wincon@3.0.2
17         anstyle@1.0.6
18         assert_cmd@2.0.14
19         autocfg@1.3.0
20         bitflags@1.3.2
21         bitflags@2.5.0
22         bstr@1.9.1
23         bumpalo@3.16.0
24         cc@1.0.97
25         cfg-if@1.0.0
26         cfg_aliases@0.1.1
27         chrono@0.4.38
28         clap@4.5.4
29         clap_builder@4.5.2
30         clap_complete@4.5.1
31         clap_lex@0.7.0
32         clap_mangen@0.2.20
33         colorchoice@1.0.0
34         config-file@0.2.3
35         core-foundation-sys@0.8.6
36         crossbeam-deque@0.8.5
37         crossbeam-epoch@0.9.18
38         crossbeam-utils@0.8.19
39         ctrlc@3.4.4
40         difflib@0.4.0
41         directories@4.0.1
42         dirs-sys@0.3.7
43         doc-comment@0.3.3
44         either@1.10.0
45         errno@0.3.8
46         fastrand@2.0.2
47         filesize@0.2.0
48         getrandom@0.2.12
49         hermit-abi@0.3.9
50         iana-time-zone-haiku@0.1.2
51         iana-time-zone@0.1.60
52         io-lifetimes@1.0.11
53         itoa@1.0.11
54         js-sys@0.3.69
55         libc@0.2.155
56         libredox@0.0.1
57         linux-raw-sys@0.3.8
58         linux-raw-sys@0.4.13
59         log@0.4.21
60         lscolors@0.13.0
61         memchr@2.7.1
62         nix@0.28.0
63         ntapi@0.4.1
64         nu-ansi-term@0.46.0
65         num-traits@0.2.19
66         once_cell@1.19.0
67         overload@0.1.1
68         predicates-core@1.0.6
69         predicates-tree@1.0.9
70         predicates@3.1.0
71         proc-macro2@1.0.79
72         quote@1.0.35
73         rayon-core@1.12.1
74         rayon@1.10.0
75         redox_syscall@0.4.1
76         redox_users@0.4.4
77         regex-automata@0.4.6
78         regex-syntax@0.8.2
79         regex@1.10.4
80         roff@0.2.1
81         rustix@0.37.27
82         rustix@0.38.32
83         ryu@1.0.17
84         serde@1.0.197
85         serde_derive@1.0.197
86         serde_json@1.0.116
87         stfu8@0.2.7
88         strsim@0.11.0
89         syn@2.0.55
90         sysinfo@0.27.8
91         tempfile@3.10.1
92         terminal_size@0.2.6
93         termtree@0.4.1
94         thiserror-impl@1.0.58
95         thiserror@1.0.58
96         thousands@0.2.0
97         toml@0.5.11
98         unicode-ident@1.0.12
99         unicode-width@0.1.11
100         utf8parse@0.2.1
101         wait-timeout@0.2.0
102         wasi@0.11.0+wasi-snapshot-preview1
103         wasm-bindgen-backend@0.2.92
104         wasm-bindgen-macro-support@0.2.92
105         wasm-bindgen-macro@0.2.92
106         wasm-bindgen-shared@0.2.92
107         wasm-bindgen@0.2.92
108         winapi-i686-pc-windows-gnu@0.4.0
109         winapi-util@0.1.8
110         winapi-x86_64-pc-windows-gnu@0.4.0
111         winapi@0.3.9
112         windows-core@0.52.0
113         windows-sys@0.48.0
114         windows-sys@0.52.0
115         windows-targets@0.48.5
116         windows-targets@0.52.4
117         windows_aarch64_gnullvm@0.48.5
118         windows_aarch64_gnullvm@0.52.4
119         windows_aarch64_msvc@0.48.5
120         windows_aarch64_msvc@0.52.4
121         windows_i686_gnu@0.48.5
122         windows_i686_gnu@0.52.4
123         windows_i686_msvc@0.48.5
124         windows_i686_msvc@0.52.4
125         windows_x86_64_gnu@0.48.5
126         windows_x86_64_gnu@0.52.4
127         windows_x86_64_gnullvm@0.48.5
128         windows_x86_64_gnullvm@0.52.4
129         windows_x86_64_msvc@0.48.5
130         windows_x86_64_msvc@0.52.4
133 inherit bash-completion-r1 cargo
135 DESCRIPTION="A more intuitive version of du"
136 # Double check the homepage as the cargo_metadata crate
137 # does not provide this value so instead repository is used
138 HOMEPAGE="https://github.com/bootandy/dust"
139 SRC_URI="
140         https://github.com/bootandy/dust/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz
141         ${CARGO_CRATE_URIS}
144 LICENSE="Apache-2.0"
145 # Dependent crate licenses
146 LICENSE+="
147         BSD-2 MIT Unicode-DFS-2016
148         || ( Apache-2.0 Boost-1.0 )
150 SLOT="0"
151 KEYWORDS="amd64 ~ppc64"
153 QA_FLAGS_IGNORED="usr/bin/dust"
155 DOCS=(
156         README.md
159 src_install() {
160         cargo_src_install
161         doman man-page/dust.1
163         newbashcomp completions/dust.bash dust
165         insinto /usr/share/fish/completions
166         doins completions/dust.fish
168         insinto /usr/share/zsh/site-functions
169         doins completions/_dust