app-admin/awscli: Bump to 1.37.9
[gentoo/gentoo.git] / sys-block / gpart / gpart-0.3-r1.ebuild
blob69972af8e9000243fb60fff875dcd5b3986c5d65
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit autotools
8 DESCRIPTION="Partition table rescue/guessing tool"
9 HOMEPAGE="https://github.com/baruch/gpart"
10 SRC_URI="https://github.com/baruch/gpart/archive/${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~hppa x86"
16 PATCHES=(
17         "${FILESDIR}"/${PN}-0.1h-errno.patch
18         "${FILESDIR}"/${PN}-0.3-build.patch
21 src_prepare() {
22         default
24         # Fix version string in build environment.
25         if [[ "$(awk -F , '/^AC_INIT/ {print $2}' configure.ac)" != ${PV} ]] ; then
26                 sed "/^AC_INIT/s@, [[:digit:]\.]\+[[:alnum:]-]*,@, ${PV},@" \
27                         -i configure.ac || die
28         fi
30         eautoreconf