2 # -*- mode: makefile; coding: utf-8 -*-
4 ifeq ($(wildcard debian
/control
),)
5 ifeq ($(DEB_AUTO_UPDATE_DEBIAN_CONTROL
),)
6 advice_about_control
:= yes
10 ifeq ($(advice_about_control
),yes
)
11 advice-on-debian-control
%::
12 @echo
"It seems you are building from pristine source and"
13 @echo
"debian/control is missing. It will be autogenerated"
16 @echo
" ./debian/rules generate"
21 DEB_PYTHON_SYSTEM
:= pysupport
23 include /usr
/share
/cdbs
/1/rules
/debhelper.mk
24 include /usr
/share
/cdbs
/1/class
/python-distutils.mk
27 rm -rf
dist gitosis.egg-info
32 # I wish this was atomic
33 cp debian
/control.in debian
/control
34 fakeroot env DEB_AUTO_UPDATE_DEBIAN_CONTROL
=1 .
/debian
/rules
clean