ignore malformatted ssh keys and go on with authorized_keys creation
[gitosis/gentoo.git] / debian / rules
blob0a0a6478e00d0e19aaa194fedf636109c56221f6
1 #!/usr/bin/make -f
2 # -*- mode: makefile; coding: utf-8 -*-
4 ifeq ($(wildcard debian/control),)
5 ifeq ($(DEB_AUTO_UPDATE_DEBIAN_CONTROL),)
6 advice_about_control := yes
7 endif
8 endif
10 ifeq ($(advice_about_control),yes)
11 advice-on-debian-control %::
12 @echo "It seems you are building from pristine source and"
13 @echo "debian/control is missing. It will be autogenerated"
14 @echo "if you say:"
15 @echo
16 @echo " ./debian/rules generate"
17 @echo
18 @exit 1
19 else
21 DEB_PYTHON_SYSTEM := pysupport
23 include /usr/share/cdbs/1/rules/debhelper.mk
24 include /usr/share/cdbs/1/class/python-distutils.mk
26 clean::
27 rm -rf dist gitosis.egg-info
28 endif
31 generate::
32 # I wish this was atomic
33 cp debian/control.in debian/control
34 fakeroot env DEB_AUTO_UPDATE_DEBIAN_CONTROL=1 ./debian/rules clean