4 # summary of how this script can be called:
5 # * <postinst> `configure' <most-recently-configured-version>
6 # * <old-postinst> `abort-upgrade' <new version>
7 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
9 # * <postinst> `abort-remove'
10 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
11 # <failed-install-package> <version> `removing'
12 # <conflicting-package> <version>
13 # for details, see http://www.debian.org/doc/debian-policy/ or
14 # the debian-policy package
18 for p
in mozilla firefox iceweasel xulrunner midbrowser
; do
19 if test -d "/usr/lib/$p/plugins"; then
20 update-alternatives
--install \
21 "/usr/lib/$p/plugins/flashplugin-alternative.so" \
23 /usr
/lib
/mozilla
/plugins
/libgnashplugin.so \
28 abort-upgrade|abort-remove|abort-deconfigure
)
32 echo "postinst called with unknown argument \`$1'" >&2
37 # dh_installdeb will replace this with shell code automatically
38 # generated by other debhelper scripts.