1 Only in gnumeric-1.10.17.orig: aclocal.m4
2 diff -ru gnumeric-1.10.17.orig/config.guess gnumeric-1.10.17/config.guess
3 --- gnumeric-1.10.17.orig/config.guess 2011-07-07 13:40:02.000000000 +0200
4 +++ gnumeric-1.10.17/config.guess 2011-08-01 13:15:45.000000000 +0200
7 # Attempt to guess a canonical system name.
8 # Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
9 -# 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009
10 -# Free Software Foundation, Inc.
11 +# 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010,
12 +# 2011 Free Software Foundation, Inc.
14 -timestamp='2009-11-20'
15 +timestamp='2011-05-11'
17 # This file is free software; you can redistribute it and/or modify it
18 # under the terms of the GNU General Public License as published by
20 GNU config.guess ($timestamp)
22 Originally written by Per Bothner.
23 -Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001,
24 -2002, 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
25 +Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000,
26 +2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011 Free
27 +Software Foundation, Inc.
29 This is free software; see the source for copying conditions. There is NO
30 warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
32 UNAME_SYSTEM=`(uname -s) 2>/dev/null` || UNAME_SYSTEM=unknown
33 UNAME_VERSION=`(uname -v) 2>/dev/null` || UNAME_VERSION=unknown
35 -case "${UNAME_MACHINE}" in
37 - test -z "$VENDOR" && VENDOR=pc
40 - test -z "$VENDOR" && VENDOR=unknown
43 -test -f /etc/SuSE-release -o -f /.buildenv && VENDOR=suse
45 # Note: order is significant - the case branches are not exclusive.
47 case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
60 UNAME_MACHINE_ARCH=`arch | sed 's/OpenBSD.//'`
61 - echo ${UNAME_MACHINE_ARCH}-${VENDOR}-openbsd${UNAME_RELEASE}
62 + echo ${UNAME_MACHINE_ARCH}-unknown-openbsd${UNAME_RELEASE}
65 - echo ${UNAME_MACHINE}-${VENDOR}-ekkobsd${UNAME_RELEASE}
66 + echo ${UNAME_MACHINE}-unknown-ekkobsd${UNAME_RELEASE}
69 - echo ${UNAME_MACHINE}-${VENDOR}-solidbsd${UNAME_RELEASE}
70 + echo ${UNAME_MACHINE}-unknown-solidbsd${UNAME_RELEASE}
73 - echo powerpc-${VENDOR}-mirbsd${UNAME_RELEASE}
74 + echo powerpc-unknown-mirbsd${UNAME_RELEASE}
77 - echo ${UNAME_MACHINE}-${VENDOR}-mirbsd${UNAME_RELEASE}
78 + echo ${UNAME_MACHINE}-unknown-mirbsd${UNAME_RELEASE}
81 case $UNAME_RELEASE in
83 UNAME_RELEASE=`/usr/sbin/sizer -v | awk '{print $3}'`
86 - UNAME_RELEASE=`/usr/sbin/sizer -v | awk '{print $4}'`
87 + UNAME_RELEASE=`/usr/sbin/sizer -v | awk '{print $4}'`
90 # According to Compaq, /usr/sbin/psrinfo has been available on
92 # A Xn.n version is an unreleased experimental baselevel.
93 # 1.2 uses "1.2" for uname -r.
94 echo ${UNAME_MACHINE}-dec-osf`echo ${UNAME_RELEASE} | sed -e 's/^[PVTX]//' | tr 'ABCDEFGHIJKLMNOPQRSTUVWXYZ' 'abcdefghijklmnopqrstuvwxyz'`
96 + # Reset EXIT trap before exiting to avoid spurious non-zero exit code.
100 Alpha\ *:Windows_NT*:*)
101 # How do we know it's Interix rather than the generic POSIX subsystem?
102 # Should we change UNAME_MACHINE based on the output of uname instead
103 @@ -290,13 +284,13 @@
104 echo alpha-dec-winnt3.5
106 Amiga*:UNIX_System_V:4.0:*)
107 - echo m68k-${VENDOR}-sysv4
108 + echo m68k-unknown-sysv4
110 *:[Aa]miga[Oo][Ss]:*:*)
111 - echo ${UNAME_MACHINE}-${VENDOR}-amigaos
112 + echo ${UNAME_MACHINE}-unknown-amigaos
114 *:[Mm]orph[Oo][Ss]:*:*)
115 - echo ${UNAME_MACHINE}-${VENDOR}-morphos
116 + echo ${UNAME_MACHINE}-unknown-morphos
119 echo i370-ibm-openedition
120 @@ -305,13 +299,13 @@
124 - echo powerpc-ibm-os400
125 + echo powerpc-ibm-os400
127 arm:RISC*:1.[012]*:*|arm:riscix:1.[012]*:*)
128 echo arm-acorn-riscix${UNAME_RELEASE}
130 arm:riscos:*:*|arm:RISCOS:*:*)
131 - echo arm-${VENDOR}-riscos
132 + echo arm-unknown-riscos
134 SR2?01:HI-UX/MPP:*:* | SR8000:HI-UX/MPP:*:*)
135 echo hppa1.1-hitachi-hiuxmpp
136 @@ -404,23 +398,23 @@
137 # MiNT. But MiNT is downward compatible to TOS, so this should
139 atarist[e]:*MiNT:*:* | atarist[e]:*mint:*:* | atarist[e]:*TOS:*:*)
140 - echo m68k-atari-mint${UNAME_RELEASE}
141 + echo m68k-atari-mint${UNAME_RELEASE}
143 atari*:*MiNT:*:* | atari*:*mint:*:* | atarist[e]:*TOS:*:*)
144 echo m68k-atari-mint${UNAME_RELEASE}
147 *falcon*:*MiNT:*:* | *falcon*:*mint:*:* | *falcon*:*TOS:*:*)
148 - echo m68k-atari-mint${UNAME_RELEASE}
149 + echo m68k-atari-mint${UNAME_RELEASE}
151 milan*:*MiNT:*:* | milan*:*mint:*:* | *milan*:*TOS:*:*)
152 - echo m68k-milan-mint${UNAME_RELEASE}
154 + echo m68k-milan-mint${UNAME_RELEASE}
156 hades*:*MiNT:*:* | hades*:*mint:*:* | *hades*:*TOS:*:*)
157 - echo m68k-hades-mint${UNAME_RELEASE}
159 + echo m68k-hades-mint${UNAME_RELEASE}
161 *:*MiNT:*:* | *:*mint:*:* | *:*TOS:*:*)
162 - echo m68k-${VENDOR}-mint${UNAME_RELEASE}
164 + echo m68k-unknown-mint${UNAME_RELEASE}
167 echo m68k-apple-machten${UNAME_RELEASE}
170 echo m88k-motorola-sysv3
173 - # DG/UX returns AViiON for all architectures
174 - UNAME_PROCESSOR=`/usr/bin/uname -p`
175 + # DG/UX returns AViiON for all architectures
176 + UNAME_PROCESSOR=`/usr/bin/uname -p`
177 if [ $UNAME_PROCESSOR = mc88100 ] || [ $UNAME_PROCESSOR = mc88110 ]
179 if [ ${TARGET_BINARY_INTERFACE}x = m88kdguxelfx ] || \
182 echo i586-dg-dgux${UNAME_RELEASE}
186 M88*:DolphinOS:*:*) # DolphinOS (SVR3)
187 echo m88k-dolphin-sysv3
190 echo rs6000-ibm-aix3.2
195 IBM_CPU_ID=`/usr/sbin/lsdev -C -c processor -S available | sed 1q | awk '{ print $1 }'`
196 if /usr/sbin/lsattr -El ${IBM_CPU_ID} | grep ' POWER' >/dev/null 2>&1; then
198 @@ -604,52 +598,52 @@
199 9000/[678][0-9][0-9])
200 if [ -x /usr/bin/getconf ]; then
201 sc_cpu_version=`/usr/bin/getconf SC_CPU_VERSION 2>/dev/null`
202 - sc_kernel_bits=`/usr/bin/getconf SC_KERNEL_BITS 2>/dev/null`
203 - case "${sc_cpu_version}" in
204 - 523) HP_ARCH="hppa1.0" ;; # CPU_PA_RISC1_0
205 - 528) HP_ARCH="hppa1.1" ;; # CPU_PA_RISC1_1
206 - 532) # CPU_PA_RISC2_0
207 - case "${sc_kernel_bits}" in
208 - 32) HP_ARCH="hppa2.0n" ;;
209 - 64) HP_ARCH="hppa2.0w" ;;
210 + sc_kernel_bits=`/usr/bin/getconf SC_KERNEL_BITS 2>/dev/null`
211 + case "${sc_cpu_version}" in
212 + 523) HP_ARCH="hppa1.0" ;; # CPU_PA_RISC1_0
213 + 528) HP_ARCH="hppa1.1" ;; # CPU_PA_RISC1_1
214 + 532) # CPU_PA_RISC2_0
215 + case "${sc_kernel_bits}" in
216 + 32) HP_ARCH="hppa2.0n" ;;
217 + 64) HP_ARCH="hppa2.0w" ;;
218 '') HP_ARCH="hppa2.0" ;; # HP-UX 10.20
224 if [ "${HP_ARCH}" = "" ]; then
225 eval $set_cc_for_build
226 - sed 's/^ //' << EOF >$dummy.c
227 + sed 's/^ //' << EOF >$dummy.c
229 - #define _HPUX_SOURCE
230 - #include <stdlib.h>
231 - #include <unistd.h>
235 - #if defined(_SC_KERNEL_BITS)
236 - long bits = sysconf(_SC_KERNEL_BITS);
238 - long cpu = sysconf (_SC_CPU_VERSION);
242 - case CPU_PA_RISC1_0: puts ("hppa1.0"); break;
243 - case CPU_PA_RISC1_1: puts ("hppa1.1"); break;
244 - case CPU_PA_RISC2_0:
245 - #if defined(_SC_KERNEL_BITS)
248 - case 64: puts ("hppa2.0w"); break;
249 - case 32: puts ("hppa2.0n"); break;
250 - default: puts ("hppa2.0"); break;
252 - #else /* !defined(_SC_KERNEL_BITS) */
253 - puts ("hppa2.0"); break;
255 - default: puts ("hppa1.0"); break;
259 + #define _HPUX_SOURCE
260 + #include <stdlib.h>
261 + #include <unistd.h>
265 + #if defined(_SC_KERNEL_BITS)
266 + long bits = sysconf(_SC_KERNEL_BITS);
268 + long cpu = sysconf (_SC_CPU_VERSION);
272 + case CPU_PA_RISC1_0: puts ("hppa1.0"); break;
273 + case CPU_PA_RISC1_1: puts ("hppa1.1"); break;
274 + case CPU_PA_RISC2_0:
275 + #if defined(_SC_KERNEL_BITS)
278 + case 64: puts ("hppa2.0w"); break;
279 + case 32: puts ("hppa2.0n"); break;
280 + default: puts ("hppa2.0"); break;
282 + #else /* !defined(_SC_KERNEL_BITS) */
283 + puts ("hppa2.0"); break;
285 + default: puts ("hppa1.0"); break;
290 (CCOPTS= $CC_FOR_BUILD -o $dummy $dummy.c 2>/dev/null) && HP_ARCH=`$dummy`
291 test -z "$HP_ARCH" && HP_ARCH=hppa
295 if [ -x /usr/sbin/sysversion ] ; then
296 - echo ${UNAME_MACHINE}-${VENDOR}-osf1mk
297 + echo ${UNAME_MACHINE}-unknown-osf1mk
299 - echo ${UNAME_MACHINE}-${VENDOR}-osf1
300 + echo ${UNAME_MACHINE}-unknown-osf1
304 @@ -740,22 +734,22 @@
306 C1*:ConvexOS:*:* | convex:ConvexOS:C1*:*)
310 C2*:ConvexOS:*:* | convex:ConvexOS:C2*:*)
311 if getsysinfo -f scalar_acc
312 then echo c32-convex-bsd
313 else echo c2-convex-bsd
317 C34*:ConvexOS:*:* | convex:ConvexOS:C34*:*)
321 C38*:ConvexOS:*:* | convex:ConvexOS:C38*:*)
325 C4*:ConvexOS:*:* | convex:ConvexOS:C4*:*)
330 echo ymp-cray-unicos${UNAME_RELEASE} | sed -e 's/\.[^.]*$/.X/'
332 @@ -779,32 +773,32 @@
334 F30[01]:UNIX_System_V:*:* | F700:UNIX_System_V:*:*)
335 FUJITSU_PROC=`uname -m | tr 'ABCDEFGHIJKLMNOPQRSTUVWXYZ' 'abcdefghijklmnopqrstuvwxyz'`
336 - FUJITSU_SYS=`uname -p | tr 'ABCDEFGHIJKLMNOPQRSTUVWXYZ' 'abcdefghijklmnopqrstuvwxyz' | sed -e 's/\///'`
337 - FUJITSU_REL=`echo ${UNAME_RELEASE} | sed -e 's/ /_/'`
338 - echo "${FUJITSU_PROC}-fujitsu-${FUJITSU_SYS}${FUJITSU_REL}"
340 + FUJITSU_SYS=`uname -p | tr 'ABCDEFGHIJKLMNOPQRSTUVWXYZ' 'abcdefghijklmnopqrstuvwxyz' | sed -e 's/\///'`
341 + FUJITSU_REL=`echo ${UNAME_RELEASE} | sed -e 's/ /_/'`
342 + echo "${FUJITSU_PROC}-fujitsu-${FUJITSU_SYS}${FUJITSU_REL}"
344 5000:UNIX_System_V:4.*:*)
345 - FUJITSU_SYS=`uname -p | tr 'ABCDEFGHIJKLMNOPQRSTUVWXYZ' 'abcdefghijklmnopqrstuvwxyz' | sed -e 's/\///'`
346 - FUJITSU_REL=`echo ${UNAME_RELEASE} | tr 'ABCDEFGHIJKLMNOPQRSTUVWXYZ' 'abcdefghijklmnopqrstuvwxyz' | sed -e 's/ /_/'`
347 - echo "sparc-fujitsu-${FUJITSU_SYS}${FUJITSU_REL}"
348 + FUJITSU_SYS=`uname -p | tr 'ABCDEFGHIJKLMNOPQRSTUVWXYZ' 'abcdefghijklmnopqrstuvwxyz' | sed -e 's/\///'`
349 + FUJITSU_REL=`echo ${UNAME_RELEASE} | tr 'ABCDEFGHIJKLMNOPQRSTUVWXYZ' 'abcdefghijklmnopqrstuvwxyz' | sed -e 's/ /_/'`
350 + echo "sparc-fujitsu-${FUJITSU_SYS}${FUJITSU_REL}"
352 i*86:BSD/386:*:* | i*86:BSD/OS:*:* | *:Ascend\ Embedded/OS:*:*)
353 echo ${UNAME_MACHINE}-pc-bsdi${UNAME_RELEASE}
356 - echo sparc-${VENDOR}-bsdi${UNAME_RELEASE}
357 + echo sparc-unknown-bsdi${UNAME_RELEASE}
360 - echo ${UNAME_MACHINE}-${VENDOR}-bsdi${UNAME_RELEASE}
361 + echo ${UNAME_MACHINE}-unknown-bsdi${UNAME_RELEASE}
364 case ${UNAME_MACHINE} in
366 - echo i386-${VENDOR}-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
367 + echo i386-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
369 - echo x86_64-${VENDOR}-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
370 + echo x86_64-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
372 - echo ${UNAME_MACHINE}-${VENDOR}-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
373 + echo ${UNAME_MACHINE}-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
377 @@ -814,22 +808,22 @@
378 echo ${UNAME_MACHINE}-pc-mingw32
381 - # uname -m includes "-pc" on this system.
382 - echo ${UNAME_MACHINE}-mingw32
383 + # uname -m includes "-pc" on this system.
384 + echo ${UNAME_MACHINE}-mingw32
387 echo ${UNAME_MACHINE}-pc-pw32
390 - case ${UNAME_MACHINE} in
391 + case ${UNAME_MACHINE} in
393 echo i586-pc-interix${UNAME_RELEASE}
395 authenticamd | genuineintel | EM64T)
396 - echo x86_64-${VENDOR}-interix${UNAME_RELEASE}
397 + echo x86_64-unknown-interix${UNAME_RELEASE}
400 - echo ia64-${VENDOR}-interix${UNAME_RELEASE}
401 + echo ia64-unknown-interix${UNAME_RELEASE}
404 [345]86:Windows_95:* | [345]86:Windows_98:* | [345]86:Windows_NT:*)
405 @@ -848,21 +842,21 @@
406 echo ${UNAME_MACHINE}-pc-uwin
408 amd64:CYGWIN*:*:* | x86_64:CYGWIN*:*:*)
409 - echo x86_64-${VENDOR}-cygwin
410 + echo x86_64-unknown-cygwin
413 - echo powerpcle-${VENDOR}-cygwin
414 + echo powerpcle-unknown-cygwin
417 - echo powerpcle-${VENDOR}-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
418 + echo powerpcle-unknown-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
422 - echo `echo ${UNAME_MACHINE}|sed -e 's,[-/].*$,,'`-${VENDOR}-gnu`echo ${UNAME_RELEASE}|sed -e 's,/.*$,,'`
423 + echo `echo ${UNAME_MACHINE}|sed -e 's,[-/].*$,,'`-unknown-gnu`echo ${UNAME_RELEASE}|sed -e 's,/.*$,,'`
426 # other systems with GNU libc and userland
427 - echo ${UNAME_MACHINE}-${VENDOR}-`echo ${UNAME_SYSTEM} | sed 's,^[^/]*/,,' | tr '[A-Z]' '[a-z]'``echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'`-gnu
428 + echo ${UNAME_MACHINE}-unknown-`echo ${UNAME_SYSTEM} | sed 's,^[^/]*/,,' | tr '[A-Z]' '[a-z]'``echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'`-gnu
431 echo ${UNAME_MACHINE}-pc-minix
432 @@ -876,23 +870,29 @@
433 EV6) UNAME_MACHINE=alphaev6 ;;
434 EV67) UNAME_MACHINE=alphaev67 ;;
435 EV68*) UNAME_MACHINE=alphaev68 ;;
438 objdump --private-headers /bin/sh | grep -q ld.so.1
439 if test "$?" = 0 ; then LIBC="libc1" ; else LIBC="" ; fi
440 - echo ${UNAME_MACHINE}-${VENDOR}-linux-gnu${LIBC}
441 + echo ${UNAME_MACHINE}-unknown-linux-gnu${LIBC}
444 eval $set_cc_for_build
445 if echo __ARM_EABI__ | $CC_FOR_BUILD -E - 2>/dev/null \
446 | grep -q __ARM_EABI__
448 - echo ${UNAME_MACHINE}-${VENDOR}-linux-gnu
449 + echo ${UNAME_MACHINE}-unknown-linux-gnu
451 - echo ${UNAME_MACHINE}-${VENDOR}-linux-gnueabi
452 + if echo __ARM_PCS_VFP | $CC_FOR_BUILD -E - 2>/dev/null \
453 + | grep -q __ARM_PCS_VFP
455 + echo ${UNAME_MACHINE}-unknown-linux-gnueabi
457 + echo ${UNAME_MACHINE}-unknown-linux-gnueabihf
462 - echo ${UNAME_MACHINE}-${VENDOR}-linux-gnu
463 + echo ${UNAME_MACHINE}-unknown-linux-gnu
466 echo cris-axis-linux-gnu
468 echo crisv32-axis-linux-gnu
471 - echo frv-${VENDOR}-linux-gnu
472 + echo frv-unknown-linux-gnu
476 @@ -912,16 +912,16 @@
479 eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep '^LIBC'`
480 - echo "${UNAME_MACHINE}-${VENDOR}-linux-${LIBC}"
481 + echo "${UNAME_MACHINE}-pc-linux-${LIBC}"
484 - echo ${UNAME_MACHINE}-${VENDOR}-linux-gnu
485 + echo ${UNAME_MACHINE}-unknown-linux-gnu
488 - echo ${UNAME_MACHINE}-${VENDOR}-linux-gnu
489 + echo ${UNAME_MACHINE}-unknown-linux-gnu
492 - echo ${UNAME_MACHINE}-${VENDOR}-linux-gnu
493 + echo ${UNAME_MACHINE}-unknown-linux-gnu
495 mips:Linux:*:* | mips64:Linux:*:*)
496 eval $set_cc_for_build
497 @@ -940,51 +940,54 @@
500 eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep '^CPU'`
501 - test x"${CPU}" != x && { echo "${CPU}-${VENDOR}-linux-gnu"; exit; }
502 + test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit; }
505 - echo or32-${VENDOR}-linux-gnu
506 + echo or32-unknown-linux-gnu
509 - echo sparc-${VENDOR}-linux-gnu
510 + echo sparc-unknown-linux-gnu
512 parisc64:Linux:*:* | hppa64:Linux:*:*)
513 - echo hppa64-${VENDOR}-linux-gnu
514 + echo hppa64-unknown-linux-gnu
516 parisc:Linux:*:* | hppa:Linux:*:*)
518 case `grep '^cpu[^a-z]*:' /proc/cpuinfo 2>/dev/null | cut -d' ' -f2` in
519 - PA7*) echo hppa1.1-${VENDOR}-linux-gnu ;;
520 - PA8*) echo hppa2.0-${VENDOR}-linux-gnu ;;
521 - *) echo hppa-${VENDOR}-linux-gnu ;;
522 + PA7*) echo hppa1.1-unknown-linux-gnu ;;
523 + PA8*) echo hppa2.0-unknown-linux-gnu ;;
524 + *) echo hppa-unknown-linux-gnu ;;
528 - echo powerpc64-${VENDOR}-linux-gnu
529 + echo powerpc64-unknown-linux-gnu
532 - echo powerpc-${VENDOR}-linux-gnu
533 + echo powerpc-unknown-linux-gnu
535 s390:Linux:*:* | s390x:Linux:*:*)
536 echo ${UNAME_MACHINE}-ibm-linux
539 - echo ${UNAME_MACHINE}-${VENDOR}-linux-gnu
540 + echo ${UNAME_MACHINE}-unknown-linux-gnu
543 - echo ${UNAME_MACHINE}-${VENDOR}-linux-gnu
544 + echo ${UNAME_MACHINE}-unknown-linux-gnu
546 sparc:Linux:*:* | sparc64:Linux:*:*)
547 - echo ${UNAME_MACHINE}-${VENDOR}-linux-gnu
548 + echo ${UNAME_MACHINE}-unknown-linux-gnu
551 + echo ${UNAME_MACHINE}-tilera-linux-gnu
554 echo ${UNAME_MACHINE}-dec-linux-gnu
557 - echo x86_64-${VENDOR}-linux-gnu
558 + echo x86_64-unknown-linux-gnu
561 - echo ${UNAME_MACHINE}-${VENDOR}-linux-gnu
562 + echo ${UNAME_MACHINE}-unknown-linux-gnu
565 # ptx 4.0 does uname -s correctly, with DYNIX/ptx in there.
566 @@ -993,11 +996,11 @@
567 echo i386-sequent-sysv4
569 i*86:UNIX_SV:4.2MP:2.*)
570 - # Unixware is an offshoot of SVR4, but it has its own version
571 - # number series starting with 2...
572 - # I am not positive that other SVR4 systems won't match this,
573 + # Unixware is an offshoot of SVR4, but it has its own version
574 + # number series starting with 2...
575 + # I am not positive that other SVR4 systems won't match this,
576 # I just have to hope. -- rms.
577 - # Use sysv4.2uw... so that sysv4* matches it.
578 + # Use sysv4.2uw... so that sysv4* matches it.
579 echo ${UNAME_MACHINE}-pc-sysv4.2uw${UNAME_VERSION}
582 @@ -1006,16 +1009,16 @@
583 echo ${UNAME_MACHINE}-pc-os2-emx
586 - echo ${UNAME_MACHINE}-${VENDOR}-stop
587 + echo ${UNAME_MACHINE}-unknown-stop
590 - echo ${UNAME_MACHINE}-${VENDOR}-atheos
591 + echo ${UNAME_MACHINE}-unknown-atheos
594 echo ${UNAME_MACHINE}-pc-syllable
596 i*86:LynxOS:2.*:* | i*86:LynxOS:3.[01]*:* | i*86:LynxOS:4.[02]*:*)
597 - echo i386-${VENDOR}-lynxos${UNAME_RELEASE}
598 + echo i386-unknown-lynxos${UNAME_RELEASE}
601 echo ${UNAME_MACHINE}-pc-msdosdjgpp
602 @@ -1029,13 +1032,13 @@
606 - # UnixWare 7.x, OpenUNIX and OpenServer 6.
607 + # UnixWare 7.x, OpenUNIX and OpenServer 6.
608 case `/bin/uname -X | grep "^Machine"` in
609 *486*) UNAME_MACHINE=i486 ;;
610 *Pentium) UNAME_MACHINE=i586 ;;
611 *Pent*|*Celeron) UNAME_MACHINE=i686 ;;
613 - echo ${UNAME_MACHINE}-${VENDOR}-sysv${UNAME_RELEASE}${UNAME_SYSTEM}${UNAME_VERSION}
614 + echo ${UNAME_MACHINE}-unknown-sysv${UNAME_RELEASE}${UNAME_SYSTEM}${UNAME_VERSION}
617 if test -f /usr/options/cb.name; then
618 @@ -1057,13 +1060,13 @@
621 # Left here for compatibility:
622 - # uname -m prints for DJGPP always 'pc', but it prints nothing about
623 - # the processor, so we play safe by assuming i586.
624 + # uname -m prints for DJGPP always 'pc', but it prints nothing about
625 + # the processor, so we play safe by assuming i586.
626 # Note: whatever this is, it MUST be the same as what config.sub
627 # prints for the "djgpp" host, or else GDB configury will decide that
628 # this is a cross-build.
629 echo i586-pc-msdosdjgpp
635 @@ -1074,7 +1077,7 @@
636 if grep Stardent /usr/include/sys/uadmin.h >/dev/null 2>&1 ; then
637 echo i860-stardent-sysv${UNAME_RELEASE} # Stardent Vistra i860-SVR4
638 else # Add other i860-SVR4 vendors below as they are discovered.
639 - echo i860-${VENDOR}-sysv${UNAME_RELEASE} # Unknown i860-SVR4
640 + echo i860-unknown-sysv${UNAME_RELEASE} # Unknown i860-SVR4
644 @@ -1098,8 +1101,8 @@
645 /bin/uname -p 2>/dev/null | /bin/grep entium >/dev/null \
646 && { echo i586-ncr-sysv4.3${OS_REL}; exit; } ;;
647 3[34]??:*:4.0:* | 3[34]??,*:*:4.0:*)
648 - /bin/uname -p 2>/dev/null | grep 86 >/dev/null \
649 - && { echo i486-ncr-sysv4; exit; } ;;
650 + /bin/uname -p 2>/dev/null | grep 86 >/dev/null \
651 + && { echo i486-ncr-sysv4; exit; } ;;
652 NCR*:*:4.2:* | MPRAS*:*:4.2:*)
654 test -r /etc/.relid \
655 @@ -1111,19 +1114,19 @@
656 /bin/uname -p 2>/dev/null | /bin/grep pteron >/dev/null \
657 && { echo i586-ncr-sysv4.3${OS_REL}; exit; } ;;
658 m68*:LynxOS:2.*:* | m68*:LynxOS:3.0*:*)
659 - echo m68k-${VENDOR}-lynxos${UNAME_RELEASE}
660 + echo m68k-unknown-lynxos${UNAME_RELEASE}
662 mc68030:UNIX_System_V:4.*:*)
663 echo m68k-atari-sysv4
665 TSUNAMI:LynxOS:2.*:*)
666 - echo sparc-${VENDOR}-lynxos${UNAME_RELEASE}
667 + echo sparc-unknown-lynxos${UNAME_RELEASE}
670 - echo rs6000-${VENDOR}-lynxos${UNAME_RELEASE}
671 + echo rs6000-unknown-lynxos${UNAME_RELEASE}
673 PowerPC:LynxOS:2.*:* | PowerPC:LynxOS:3.[01]*:* | PowerPC:LynxOS:4.[02]*:*)
674 - echo powerpc-${VENDOR}-lynxos${UNAME_RELEASE}
675 + echo powerpc-unknown-lynxos${UNAME_RELEASE}
678 echo mips-dde-sysv${UNAME_RELEASE}
679 @@ -1142,10 +1145,10 @@
683 - PENTIUM:*:4.0*:*) # Unisys `ClearPath HMP IX 4000' SVR4/MP effort
684 - # says <Richard.M.Bartel@ccMail.Census.GOV>
685 - echo i586-unisys-sysv4
687 + PENTIUM:*:4.0*:*) # Unisys `ClearPath HMP IX 4000' SVR4/MP effort
688 + # says <Richard.M.Bartel@ccMail.Census.GOV>
689 + echo i586-unisys-sysv4
691 *:UNIX_System_V:4*:FTX*)
692 # From Gerald Hewes <hewes@openmarket.com>.
693 # How about differentiating between stratus architectures? -djm
694 @@ -1171,11 +1174,11 @@
696 R[34]000:*System_V*:*:* | R4000:UNIX_SYSV:*:* | R*000:UNIX_SV:*:*)
697 if [ -d /usr/nec ]; then
698 - echo mips-nec-sysv${UNAME_RELEASE}
699 + echo mips-nec-sysv${UNAME_RELEASE}
701 - echo mips-${VENDOR}-sysv${UNAME_RELEASE}
702 + echo mips-unknown-sysv${UNAME_RELEASE}
706 BeBox:BeOS:*:*) # BeOS running on hardware made by Be, PPC only.
709 @@ -1240,6 +1243,9 @@
713 + NEO-?:NONSTOP_KERNEL:*:*)
714 + echo neo-tandem-nsk${UNAME_RELEASE}
716 NSE-?:NONSTOP_KERNEL:*:*)
717 echo nse-tandem-nsk${UNAME_RELEASE}
719 @@ -1264,13 +1270,13 @@
721 UNAME_MACHINE="$cputype"
723 - echo ${UNAME_MACHINE}-${VENDOR}-plan9
724 + echo ${UNAME_MACHINE}-unknown-plan9
727 - echo pdp10-${VENDOR}-tops10
728 + echo pdp10-unknown-tops10
731 - echo pdp10-${VENDOR}-tenex
732 + echo pdp10-unknown-tenex
734 KS10:TOPS-20:*:* | KL10:TOPS-20:*:* | TYPE4:TOPS-20:*:*)
735 echo pdp10-dec-tops20
736 @@ -1279,19 +1285,19 @@
737 echo pdp10-xkl-tops20
740 - echo pdp10-${VENDOR}-tops20
741 + echo pdp10-unknown-tops20
744 - echo pdp10-${VENDOR}-its
745 + echo pdp10-unknown-its
748 - echo mips-sei-seiux${UNAME_RELEASE}
749 + echo mips-sei-seiux${UNAME_RELEASE}
752 - echo ${UNAME_MACHINE}-${VENDOR}-dragonfly`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'`
753 + echo ${UNAME_MACHINE}-unknown-dragonfly`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'`
756 - UNAME_MACHINE=`(uname -p) 2>/dev/null`
757 + UNAME_MACHINE=`(uname -p) 2>/dev/null`
758 case "${UNAME_MACHINE}" in
759 A*) echo alpha-dec-vms ; exit ;;
760 I*) echo ia64-dec-vms ; exit ;;
761 @@ -1331,11 +1337,11 @@
762 #include <sys/param.h>
763 printf ("m68k-sony-newsos%s\n",
776 diff -ru gnumeric-1.10.17.orig/config.sub gnumeric-1.10.17/config.sub
777 --- gnumeric-1.10.17.orig/config.sub 2011-07-07 13:40:02.000000000 +0200
778 +++ gnumeric-1.10.17/config.sub 2011-08-01 13:15:45.000000000 +0200
781 # Configuration validation subroutine script.
782 # Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
783 -# 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009
784 -# Free Software Foundation, Inc.
785 +# 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010,
786 +# 2011 Free Software Foundation, Inc.
788 -timestamp='2009-11-20'
789 +timestamp='2011-03-23'
791 # This file is (in principle) common to ALL GNU software.
792 # The presence of a machine in this file suggests that SOME GNU software
795 GNU config.sub ($timestamp)
797 -Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001,
798 -2002, 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
799 +Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000,
800 +2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011 Free
801 +Software Foundation, Inc.
803 This is free software; see the source for copying conditions. There is NO
804 warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
806 # Here we must recognize all the valid KERNEL-OS combinations.
807 maybe_os=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\2/'`
809 - nto-qnx* | linux-gnu* | linux-dietlibc | linux-newlib* | linux-uclibc* | \
810 - uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | knetbsd*-gnu* | netbsd*-gnu* | \
811 + nto-qnx* | linux-gnu* | linux-android* | linux-dietlibc | linux-newlib* | \
812 + linux-uclibc* | uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | \
813 + knetbsd*-gnu* | netbsd*-gnu* | \
814 kopensolaris*-gnu* | \
815 storm-chaos* | os2-emx* | rtmk-nova*)
826 -sim | -cisco | -oki | -wec | -winbond)
828 @@ -173,10 +175,10 @@
842 @@ -281,11 +283,13 @@
846 + | nds32 | nds32le | nds32be \
851 | pdp10 | pdp11 | pj | pjl \
852 - | powerpc | powerpc64 | powerpc64le | powerpcle | ppcbe \
853 + | powerpc | powerpc64 | powerpc64le | powerpcle \
857 @@ -293,15 +297,24 @@
859 | sparc | sparc64 | sparc64b | sparc64v | sparc86x | sparclet | sparclite \
860 | sparcv8 | sparcv9 | sparcv9b | sparcv9v \
861 - | spu | strongarm \
862 - | tahoe | thumb | tic4x | tic80 | tron \
864 + | tahoe | tic4x | tic54x | tic55x | tic6x | tic80 | tron \
868 - | x86 | xc16x | xscale | xscalee[bl] | xstormy16 | xtensa \
869 + | x86 | xc16x | xstormy16 | xtensa \
871 basic_machine=$basic_machine-unknown
874 + basic_machine=tic54x-unknown
877 + basic_machine=tic55x-unknown
880 + basic_machine=tic6x-unknown
882 m6811 | m68hc11 | m6812 | m68hc12 | picochip)
883 # Motorola 68HC11/12.
884 basic_machine=$basic_machine-unknown
886 basic_machine=mt-unknown
889 + strongarm | thumb | xscale)
890 + basic_machine=arm-unknown
894 + basic_machine=armeb-unknown
898 + basic_machine=armel-unknown
901 # We use `pc' rather than `unknown'
902 # because (1) that's what they normally are, and
903 # (2) the word "unknown" tends to confuse beginning users.
905 | arm-* | armbe-* | armle-* | armeb-* | armv*-* \
907 | bfin-* | bs2000-* \
908 - | c[123]* | c30-* | [cjt]90-* | c4x-* | c54x-* | c55x-* | c6x-* \
909 + | c[123]* | c30-* | [cjt]90-* | c4x-* \
910 | clipper-* | craynv-* | cydra-* \
911 | d10v-* | d30v-* | dlx-* \
913 @@ -367,25 +392,28 @@
917 + | nds32-* | nds32le-* | nds32be-* \
919 | none-* | np1-* | ns16k-* | ns32k-* \
922 | pdp10-* | pdp11-* | pj-* | pjl-* | pn-* | power-* \
923 - | powerpc-* | powerpc64-* | powerpc64le-* | powerpcle-* | ppcbe-* \
924 + | powerpc-* | powerpc64-* | powerpc64le-* | powerpcle-* \
926 | romp-* | rs6000-* | rx-* \
927 | sh-* | sh[1234]-* | sh[24]a-* | sh[24]aeb-* | sh[23]e-* | sh[34]eb-* | sheb-* | shbe-* \
928 | shle-* | sh[1234]le-* | sh3ele-* | sh64-* | sh64le-* \
929 | sparc-* | sparc64-* | sparc64b-* | sparc64v-* | sparc86x-* | sparclet-* \
931 - | sparcv8-* | sparcv9-* | sparcv9b-* | sparcv9v-* | strongarm-* | sv1-* | sx?-* \
932 - | tahoe-* | thumb-* \
933 - | tic30-* | tic4x-* | tic54x-* | tic55x-* | tic6x-* | tic80-* | tile-* \
934 + | sparcv8-* | sparcv9-* | sparcv9b-* | sparcv9v-* | sv1-* | sx?-* \
936 + | tic30-* | tic4x-* | tic54x-* | tic55x-* | tic6x-* | tic80-* \
937 + | tile-* | tilegx-* \
940 | v850-* | v850e-* | vax-* \
942 - | x86-* | x86_64-* | xc16x-* | xps100-* | xscale-* | xscalee[bl]-* \
943 + | x86-* | x86_64-* | xc16x-* | xps100-* \
944 | xstormy16-* | xtensa*-* \
948 basic_machine=a29k-amd
953 basic_machine=abacus-unknown
956 @@ -480,11 +508,20 @@
957 basic_machine=powerpc-ibm
961 + basic_machine=tic54x-`echo $basic_machine | sed 's/^[^-]*-//'`
964 + basic_machine=tic55x-`echo $basic_machine | sed 's/^[^-]*-//'`
967 + basic_machine=tic6x-`echo $basic_machine | sed 's/^[^-]*-//'`
970 basic_machine=c90-cray
975 basic_machine=arm-unknown
979 basic_machine=craynv-cray
984 basic_machine=cr16-unknown
988 basic_machine=ns32k-utek
993 basic_machine=microblaze-xilinx
998 basic_machine=np1-gould
1001 + basic_machine=neo-tandem
1004 + basic_machine=nse-tandem
1007 basic_machine=nsr-tandem
1009 @@ -921,9 +964,10 @@
1011 power) basic_machine=power-ibm
1013 - ppc) basic_machine=powerpc-unknown
1014 + ppc | ppcbe) basic_machine=powerpc-unknown
1016 - ppc-*) basic_machine=powerpc-`echo $basic_machine | sed 's/^[^-]*-//'`
1018 + basic_machine=powerpc-`echo $basic_machine | sed 's/^[^-]*-//'`
1020 ppcle | powerpclittle | ppc-le | powerpc-little)
1021 basic_machine=powerpcle-unknown
1022 @@ -1017,6 +1061,9 @@
1023 basic_machine=i860-stratus
1026 + strongarm-* | thumb-*)
1027 + basic_machine=arm-`echo $basic_machine | sed 's/^[^-]*-//'`
1030 basic_machine=m68000-sun
1032 @@ -1073,17 +1120,10 @@
1033 basic_machine=t90-cray
1037 - basic_machine=tic54x-unknown
1041 - basic_machine=tic55x-unknown
1045 - basic_machine=tic6x-unknown
1047 + # This must be matched before tile*.
1049 + basic_machine=tilegx-unknown
1053 basic_machine=tile-unknown
1054 @@ -1156,6 +1196,9 @@
1056 basic_machine=xps100-honeywell
1058 + xscale-* | xscalee[bl]-*)
1059 + basic_machine=`echo $basic_machine | sed 's/^xscale/arm/'`
1062 basic_machine=ymp-cray
1064 @@ -1253,11 +1296,11 @@
1065 if [ x"$os" != x"" ]
1068 - # First match some system type aliases
1069 - # that might get confused with valid system types.
1070 + # First match some system type aliases
1071 + # that might get confused with valid system types.
1072 # -solaris* is a basic system type, with this one exception.
1078 -solaris1 | -solaris1.*)
1079 os=`echo $os | sed -e 's|solaris1|sunos4|'`
1080 @@ -1294,7 +1337,8 @@
1081 | -udi* | -eabi* | -lites* | -ieee* | -go32* | -aux* \
1082 | -chorusos* | -chorusrdb* | -cegcc* \
1083 | -cygwin* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
1084 - | -mingw32* | -linux-gnu* | -linux-newlib* | -linux-uclibc* \
1085 + | -mingw32* | -linux-gnu* | -linux-android* \
1086 + | -linux-newlib* | -linux-uclibc* \
1087 | -uxpv* | -beos* | -mpeix* | -udk* \
1088 | -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
1089 | -openstep* | -oskit* | -conix* | -pw32* | -nonstopux* \
1090 @@ -1341,7 +1385,7 @@
1099 @@ -1390,7 +1434,7 @@
1108 @@ -1435,6 +1479,8 @@
1117 @@ -1457,10 +1503,10 @@
1118 # system, and we'll never get to this point.
1120 case $basic_machine in
1130 @@ -1472,8 +1518,17 @@
1148 # This must come before the *-dec entry.
1150 @@ -1500,7 +1555,7 @@
1159 @@ -1527,7 +1582,7 @@