2 # debian/rules file - for GNUPG (1.0.5)
3 # Based on sample debian/rules file - for GNU Hello (1.3).
4 # Copyright 1994,1995 by Ian Jackson.
5 # Copyright 1998 James Troup
6 # I hereby give you perpetual unlimited permission to copy,
7 # modify and relicense this file, provided that you do not remove
8 # my name from the file itself. (I assert my moral right of
9 # paternity under the Copyright, Designs and Patents Act 1988.)
10 # This file may have to be extensively modified
12 STRIP
=strip --remove-section
=.comment
--remove-section
=.note
16 .
/configure
--prefix=/usr
--with-included-gettext
22 make
-C checks
check || exit
127
28 -$(MAKE
) -i
distclean ||
$(MAKE
) -f Makefile.in
distclean
29 -rm -rf debian
/tmp debian
/*~ debian
/files
* debian
/substvars
33 binary-arch
: checkroot build
# test
36 install -d debian
/tmp
/DEBIAN
/
37 install -m
755 debian
/preinst debian
/prerm debian
/postinst debian
/tmp
/DEBIAN
/
38 $(MAKE
) prefix=`pwd`/debian
/tmp
/usr
mandir=`pwd`/debian
/tmp
/usr
/share
/man
install
39 # copies of the manpage which can't be grokked by install-info
40 rm debian
/tmp
/usr
/info/*
41 $(STRIP
) debian
/tmp
/usr
/bin
/*
42 chmod
4755 debian
/tmp
/usr
/bin
/gpg
43 chmod
644 debian
/tmp
/usr
/lib
/gnupg
/*
44 sed
-e
"s#../g10/gpg#gpg#" < tools
/lspgpot
> debian
/tmp
/usr
/bin
/lspgpot
45 chmod
755 debian
/tmp
/usr
/bin
/lspgpot
46 $(STRIP
) --strip-unneeded debian
/tmp
/usr
/lib
/gnupg
/*
47 # In response to #53714... no idea if it's correct, will check with upstream
48 mv debian
/tmp
/usr
/share
/locale
/es_ES debian
/tmp
/usr
/share
/locale
/es
49 sed
-e
"s#/usr/local/#/usr/#" < debian
/tmp
/usr
/share
/man
/man1
/gpg
.1 \
50 > debian
/tmp
/usr
/share
/man
/man1
/gpg
.1.new
51 mv debian
/tmp
/usr
/share
/man
/man1
/gpg
.1.new debian
/tmp
/usr
/share
/man
/man1
/gpg
.1
52 gzip
-9v debian
/tmp
/usr
/share
/man
/man1
/*
53 # Remove from /usr/share/gnupg that we install into /usr/share/doc/gnupg/
54 rm debian
/tmp
/usr
/share
/gnupg
/FAQ debian
/tmp
/usr
/share
/gnupg
/faq.html
55 install -d debian
/tmp
/usr
/share
/doc
/gnupg
/
56 install -m
644 debian
/changelog debian
/tmp
/usr
/share
/doc
/gnupg
/changelog.Debian
57 install -m
644 debian
/README.Debian README NEWS THANKS TODO doc
/DETAILS \
58 doc
/FAQ doc
/faq.html doc
/OpenPGP debian
/tmp
/usr
/share
/doc
/gnupg
/
59 for i in po util mpi cipher tools g10 checks
include; do \
60 install -m
644 $$i/ChangeLog debian
/tmp
/usr
/share
/doc
/gnupg
/changelog.
$$i; done
61 install -m
644 ChangeLog debian
/tmp
/usr
/share
/doc
/gnupg
/changelog.toplevel
62 gzip
-9v debian
/tmp
/usr
/share
/doc
/gnupg
/*
63 ln
-s changelog.g10.gz debian
/tmp
/usr
/share
/doc
/gnupg
/changelog.gz
64 install -m
644 debian
/copyright debian
/tmp
/usr
/share
/doc
/gnupg
/
65 install -d debian
/tmp
/usr
/share
/lintian
/overrides
/
66 install -m
644 debian
/lintian.
override debian
/tmp
/usr
/share
/lintian
/overrides
/gnupg
67 dpkg-shlibdeps g10
/gpg
69 chown
-R root.root debian
/tmp
70 chmod
-R go
=rX debian
/tmp
71 dpkg
--build debian
/tmp ..
74 test -f g10
/g10.c
-a
-f debian
/rules
77 # Below here is fairly generic really
79 binary
: binary-indep binary-arch
83 test root
= "`whoami`"
85 .PHONY
: binary binary-arch binary-indep
clean checkroot