[e1000] Use PCI_BASE_ADDRESS_* symbols instead of integers
[gpxe.git] / contrib / initrd / mkinitrd-net.spec
blob94f5d9dbfd0a4122220be15e9918b910fb22bcf0
1 %define name mkinitrd-net
2 %define version 1.10
3 %define release 1fs
5 Summary: Network-booting initrd builder
6 Name: %{name}
7 Version: %{version}
8 Release: %{release}
9 Source0: %{name}-%{version}.tar.bz2
10 Source1: http://belnet.dl.sourceforge.net/sourceforge/etherboot/mknbi-1.2.tar.bz2
11 Source2: http://www.busybox.net/downloads/busybox-0.60.3.tar.bz2
12 Source3: http://www.uclibc.org/downloads/uClibc-0.9.11.tar.bz2
13 Source4: ftp://ftp.linux-wlan.org/pub/linux-wlan-ng/linux-wlan-ng-0.1.13.tar.bz2
14 Source5: http://udhcp.busybox.net/source/udhcp-0.9.7.tar.bz2
15 Copyright: GPL/LGPL/MPL
16 Group: System/Kernel and hardware
17 BuildRoot: %{_tmppath}/%{name}-buildroot
18 Prefix: %{_prefix}
19 Requires: tftp-server
21 %description
22 mkinitrd-net allows you to build initial ramdisk images (initrds) suitable
23 for use with Etherboot and other network-booting software. This package
24 contains two main utilities: mkinitrd-net (to build an initrd containing a
25 specified set of network-card modules) and mknbi (to generate
26 Etherboot-usable NBI images from a given kernel and initrd). It also
27 contains a helper script mknbi-set which will maintain sets of initrds to
28 match all your currently-installed kernels.
30 mkinitrd-net uses code from the uClibc, busybox, udhcp and Etherboot
31 projects.
33 %prep
34 %setup -n initrd -a1 -a2 -a3 -a4 -a5
36 %build
37 %make LIBDIR=%{_libdir}/mknbi
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 %makeinstall tftpbootdir=$RPM_BUILD_ROOT%{_localstatedir}/tftpboot
42 touch $RPM_BUILD_ROOT%{_sysconfdir}/dhcpd.conf.etherboot-pcimap.include
43 ln -s %{_localstatedir}/tftpboot $RPM_BUILD_ROOT/tftpboot
45 %clean
46 rm -rf $RPM_BUILD_ROOT
48 %post
49 %{_bindir}/mknbi-set
51 %triggerin -- kernel kernel-smp kernel-secure kernel-enterprise
52 %{_bindir}/mknbi-set
54 %files
55 %defattr(-,root,root)
56 %config(noreplace) %{_sysconfdir}/mknbi-set.conf
57 %config(noreplace) %{_sysconfdir}/dhcpd.conf.etherboot.include
58 %ghost %{_sysconfdir}/dhcpd.conf.etherboot-pcimap.include
59 %{_bindir}/mknbi-*
60 %{_bindir}/mkelf-*
61 %{_bindir}/dis*
62 %{_bindir}/mkinitrd-net
63 %{_bindir}/include-modules
64 %{_libdir}/mknbi
65 %{_libdir}/mkinitrd-net
66 %{_mandir}/man*/*
67 /tftpboot
68 %{_localstatedir}/tftpboot
69 %doc README
70 %doc AUTHORS.busybox LICENSE.busybox
71 %doc AUTHORS.udhcpc COPYING.udhcpc
72 %doc COPYING.wlanctl LICENSE.wlanctl THANKS.wlanctl
73 %doc COPYING.uClibc
74 %docdir %{_docdir}/mknbi*
75 %{_docdir}/mknbi*
77 %changelog
78 * Fri Jul 26 2002 Michael Brown <mbrown@fensystems.co.uk> 1.10-1fs
79 - Support for new binary etherboot.nic-dev-id structure
80 - Added --kernel option patch from Stew Benedict at MandrakeSoft
81 - Only try to use sudo if we are not already root
83 * Wed Jun 05 2002 Michael Brown <mbrown@fensystems.co.uk> 1.9-1fs
84 - Modifications to allow DHCP, TFTP and NFS servers to be separate machines.
86 * Thu May 30 2002 Michael Brown <mbrown@fensystems.co.uk> 1.8-1fs
87 - /tftpboot symlinked to /var/lib/tftpboot
88 - Has ability to be quiet if "quiet" specified on kernel cmdline
90 * Sun May 26 2002 Michael Brown <mbrown@fensystems.co.uk> 1.7-1fs
91 - PCI-ID auto-mapping via dhcpd.conf.etherboot-pcimap.include
93 * Fri May 24 2002 Michael Brown <mbrown@fensystems.co.uk> 1.6-1fs
94 - Bugfixes, migrated /tftpboot to /var/lib/tftpboot
96 * Thu May 23 2002 Michael Brown <mbrown@fensystems.co.uk> 1.5-1fs
97 - Now includes dhcpd.conf.etherboot.include
98 - Automatically scans for all network modules in the pcimap file
100 * Wed May 08 2002 Michael Brown <mbrown@fensystems.co.uk> 1.4-1fs
101 - Bugfixes: tmpdir selection, linuxrc typos, ifconfig peculiarities
103 * Sat May 04 2002 Michael Brown <mbrown@fensystems.co.uk> 1.3-1fs
104 - During %make, LIBDIR must be set for mknbi
105 - Added %post scriptlet since %trigger seems not to be being triggered...
107 * Sat May 04 2002 Michael Brown <mbrown@fensystems.co.uk> 1.2-1fs
108 - Added extra sources instead of requiring "make" to download them
110 * Sat May 04 2002 Michael Brown <mbrown@fensystems.co.uk> 1.1-1fs
111 - First attempt at an RPM package