Tcl installs private headers. Also, make installation nicer.
[gumsense-br.git] / package / pcmciautils / pcmciautils.mk
bloba574c006dfb21c87ec75db7af45f10644dfd184b
1 #############################################################
3 # pcmciautils for udev based pcmcia control
5 #############################################################
6 # Copyright (C) 2001-2003 by Erik Andersen <andersen@codepoet.org>
7 # Copyright (C) 2002 by Tim Riker <Tim@Rikers.org>
9 # This program is free software; you can redistribute it and/or modify
10 # it under the terms of the GNU Library General Public License as
11 # published by the Free Software Foundation; either version 2 of the
12 # License, or (at your option) any later version.
14 # This program is distributed in the hope that it will be useful, but
15 # WITHOUT ANY WARRANTY; without even the implied warranty of
16 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
17 # Library General Public License for more details.
19 # You should have received a copy of the GNU Library General Public
20 # License along with this program; if not, write to the Free Software
21 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
22 # USA
24 PCMCIAUTILS_VERSION:=014
25 PCMCIAUTILS_SOURCE:=pcmciautils-$(PCMCIAUTILS_VERSION).tar.bz2
26 PCMCIAUTILS_SITE:=http://www.kernel.org/pub/linux/utils/kernel/pcmcia
27 PCMCIAUTILS_DIR:=$(BUILD_DIR)/pcmciautils-$(PCMCIAUTILS_VERSION)
28 PCMCIAUTILS_CAT:=bzcat
30 $(DL_DIR)/$(PCMCIAUTILS_SOURCE):
31 $(WGET) -P $(DL_DIR) $(PCMCIAUTILS_SITE)/$(PCMCIAUTILS_SOURCE)
33 pcmciautils-source: $(DL_DIR)/$(PCMCIAUTILS_SOURCE)
35 $(PCMCIAUTILS_DIR)/Makefile: $(DL_DIR)/$(PCMCIAUTILS_SOURCE)
36 $(PCMCIAUTILS_CAT) $(DL_DIR)/$(PCMCIAUTILS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
37 toolchain/patch-kernel.sh $(PCMCIAUTILS_DIR) package/pcmciautils pcmciautils-*.patch
38 touch $@
40 $(TARGET_DIR)/etc/udev/rules.d/60-pcmcia.rules: $(PCMCIAUTILS_DIR)/Makefile
41 $(MAKE) -C $(PCMCIAUTILS_DIR) V=true SYMLINK="ln -sf" CROSS="$(KERNEL_CROSS)" DESTDIR="$(TARGET_DIR)" STARTUP="false" UDEV="true" all
42 $(MAKE) -C $(PCMCIAUTILS_DIR) V=true SYMLINK="ln -sf" CROSS="$(KERNEL_CROSS)" DESTDIR="$(TARGET_DIR)" STARTUP="false" UDEV="true" install-udev install-tools
44 pcmciautils: udev libsysfs $(TARGET_DIR)/etc/udev/rules.d/60-pcmcia.rules
46 pcmciautils-clean:
47 rm $(TARGET_DIR)/etc/udev/rules.d/60-pcmcia-rules
49 pcmciautils-dirclean:
50 rm -rf $(PCMCIAUTILS_DIR)
51 #############################################################
53 # Toplevel Makefile options
55 #############################################################
56 ifeq ($(strip $(BR2_PACKAGE_PCMCIAUTILS)),y)
57 TARGETS+=pcmciautils
58 endif