1 #############################################################
5 #############################################################
6 PLAYER_SOURCE
:=player-1.6
.2.
tar.gz
7 PLAYER_SITE
:=http
://$(BR2_SOURCEFORGE_MIRROR
).dl.sourceforge.net
/sourceforge
/playerstage
/
9 PLAYER_DIR
:=$(BUILD_DIR
)/player-1.6
.2
12 PLAYER_TARGET_BINARY
:=usr
/bin
/player
14 $(DL_DIR
)/$(PLAYER_SOURCE
):
15 $(WGET
) -P
$(DL_DIR
) $(PLAYER_SITE
)/$(PLAYER_SOURCE
)
17 player-source
: $(DL_DIR
)/$(PLAYER_SOURCE
)
19 $(PLAYER_DIR
)/.unpacked
: $(DL_DIR
)/$(PLAYER_SOURCE
)
20 $(PLAYER_CAT
) $(DL_DIR
)/$(PLAYER_SOURCE
) |
tar -C
$(BUILD_DIR
) $(TAR_OPTIONS
) -
21 toolchain
/patch-kernel.sh
$(PLAYER_DIR
) package
/player player\
*.patch
22 touch
$(PLAYER_DIR
)/.unpacked
24 $(PLAYER_DIR
)/.configured
: $(PLAYER_DIR
)/.unpacked
25 (cd
$(PLAYER_DIR
); rm -rf config.cache
; \
26 $(TARGET_CONFIGURE_OPTS
) \
27 CFLAGS
="$(TARGET_CFLAGS)" \
33 --disable-amtecpowercube \
34 --disable-bumpersafe \
35 --disable-camera1394 \
36 --disable-cameracompress \
38 --disable-cannonvcc4 \
45 --disable-highspeedsick \
51 --disable-laserbarcode \
52 --disable-lasercspace \
53 --disable-laservisualbarcode \
54 --disable-laservisualbw \
55 --disable-libplayerc-py \
57 --disable-linuxjoystick \
63 --disable-microstrain \
67 --disable-passthrough \
68 --disable-playerclient_thread \
73 --disable-service_adv_lsd \
74 --disable-service_adv_mdns \
75 --disable-sicklms200 \
77 --disable-simpleshape \
78 --disable-sonyevid30 \
81 --disable-upcbarcode \
85 --disable-clodbuster \
87 --disable-fixedtones \
88 --disable-flockofbirds\
89 --target
=$(GNU_TARGET_NAME
) \
90 --host
=$(GNU_TARGET_NAME
) \
91 --build
=$(GNU_HOST_NAME
) \
96 --libexecdir
=/usr
/lib \
98 --datadir=/usr
/share \
99 --localstatedir
=/var \
101 --infodir=/usr
/info \
103 $(DISABLE_LARGEFILE
) \
105 touch
$(PLAYER_DIR
)/.configured
107 $(PLAYER_DIR
)/$(PLAYER_BINARY
): $(PLAYER_DIR
)/.configured
108 $(MAKE
) -C
$(PLAYER_DIR
)
110 $(TARGET_DIR
)/$(PLAYER_TARGET_BINARY
): $(PLAYER_DIR
)/$(PLAYER_BINARY
)
111 $(MAKE
) DESTDIR
=$(TARGET_DIR
) -C
$(PLAYER_DIR
) install
113 player
: uclibc jpeg
$(TARGET_DIR
)/$(PLAYER_TARGET_BINARY
)
116 $(MAKE
) DESTDIR
=$(TARGET_DIR
) -C
$(PLAYER_DIR
) uninstall
117 -$(MAKE
) -C
$(PLAYER_DIR
) clean
122 #############################################################
124 # Toplevel Makefile options
126 #############################################################
127 ifeq ($(strip $(BR2_PACKAGE_PLAYER
)),y
)