Tcl build fix
[gumsense-br.git] / package / player / player.mk
blob4556f1b105dbe6a3a1136598348e42b105fef706
1 #############################################################
3 # player
5 #############################################################
6 PLAYER_SOURCE:=player-1.6.2.tar.gz
7 PLAYER_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/playerstage/
9 PLAYER_DIR:=$(BUILD_DIR)/player-1.6.2
10 PLAYER_CAT:=zcat
11 PLAYER_BINARY:=player
12 PLAYER_TARGET_BINARY:=usr/bin/player
14 $(DL_DIR)/$(PLAYER_SOURCE):
15 $(WGET) -P $(DL_DIR) $(PLAYER_SITE)/$(PLAYER_SOURCE)
17 player-source: $(DL_DIR)/$(PLAYER_SOURCE)
19 $(PLAYER_DIR)/.unpacked: $(DL_DIR)/$(PLAYER_SOURCE)
20 $(PLAYER_CAT) $(DL_DIR)/$(PLAYER_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
21 toolchain/patch-kernel.sh $(PLAYER_DIR) package/player player\*.patch
22 touch $(PLAYER_DIR)/.unpacked
24 $(PLAYER_DIR)/.configured: $(PLAYER_DIR)/.unpacked
25 (cd $(PLAYER_DIR); rm -rf config.cache; \
26 $(TARGET_CONFIGURE_OPTS) \
27 CFLAGS="$(TARGET_CFLAGS)" \
28 ./configure \
29 --without-rtk \
30 --disable-acoustics \
31 --disable-acts \
32 --disable-amcl \
33 --disable-amtecpowercube \
34 --disable-bumpersafe \
35 --disable-camera1394 \
36 --disable-cameracompress \
37 --disable-camerav4l \
38 --disable-cannonvcc4 \
39 --disable-cmucam2 \
40 --disable-cmvision \
41 --disable-dummy \
42 --disable-festival \
43 --enable-garminnmea \
44 --disable-gazebo \
45 --disable-highspeedsick \
46 --disable-imageseq \
47 --disable-isense \
48 --disable-iwspy \
49 --disable-khepera \
50 --disable-laserbar \
51 --disable-laserbarcode \
52 --disable-lasercspace \
53 --disable-laservisualbarcode \
54 --disable-laservisualbw \
55 --disable-libplayerc-py \
56 --disable-lifomcom \
57 --disable-linuxjoystick \
58 --disable-linuxwifi \
59 --disable-logfile \
60 --disable-mapcspace \
61 --disable-mapfile \
62 --disable-mapscale \
63 --disable-microstrain \
64 --disable-mixer \
65 --disable-obot \
66 --disable-p2os \
67 --disable-passthrough \
68 --disable-playerclient_thread \
69 --disable-ptu46 \
70 --disable-reb \
71 --disable-rflex \
72 --disable-segwayrmp \
73 --disable-service_adv_lsd \
74 --disable-service_adv_mdns \
75 --disable-sicklms200 \
76 --disable-sickpls \
77 --disable-simpleshape \
78 --disable-sonyevid30 \
79 --enable-stage \
80 --disable-tests \
81 --disable-upcbarcode \
82 --disable-vfh \
83 --disable-waveaudio \
84 --disable-wavefront \
85 --disable-clodbuster \
86 --disable-er1 \
87 --disable-fixedtones \
88 --disable-flockofbirds\
89 --target=$(GNU_TARGET_NAME) \
90 --host=$(GNU_TARGET_NAME) \
91 --build=$(GNU_HOST_NAME) \
92 --prefix=/usr \
93 --exec-prefix=/usr \
94 --bindir=/usr/bin \
95 --sbindir=/usr/sbin \
96 --libexecdir=/usr/lib \
97 --sysconfdir=/etc \
98 --datadir=/usr/share \
99 --localstatedir=/var \
100 --mandir=/usr/man \
101 --infodir=/usr/info \
102 $(DISABLE_NLS) \
103 $(DISABLE_LARGEFILE) \
105 touch $(PLAYER_DIR)/.configured
107 $(PLAYER_DIR)/$(PLAYER_BINARY): $(PLAYER_DIR)/.configured
108 $(MAKE) -C $(PLAYER_DIR)
110 $(TARGET_DIR)/$(PLAYER_TARGET_BINARY): $(PLAYER_DIR)/$(PLAYER_BINARY)
111 $(MAKE) DESTDIR=$(TARGET_DIR) -C $(PLAYER_DIR) install
113 player: uclibc jpeg $(TARGET_DIR)/$(PLAYER_TARGET_BINARY)
115 player-clean:
116 $(MAKE) DESTDIR=$(TARGET_DIR) -C $(PLAYER_DIR) uninstall
117 -$(MAKE) -C $(PLAYER_DIR) clean
119 player-dirclean:
120 rm -rf $(PLAYER_DIR)
122 #############################################################
124 # Toplevel Makefile options
126 #############################################################
127 ifeq ($(strip $(BR2_PACKAGE_PLAYER)),y)
128 TARGETS+=player
129 endif