Tcl build fix
[gumsense-br.git] / package / microcom / microcom.mk
blob66cfacc7e5daee63bd570edf9b54ebb784e060ac
1 #############################################################
3 # microcom terminal emulator
5 # Maintainer: Tim Riker <Tim@Rikers.org>
7 #############################################################
8 # Copyright (C) 2001-2003 by Erik Andersen <andersen@codepoet.org>
9 # Copyright (C) 2002 by Tim Riker <Tim@Rikers.org>
11 # This program is free software; you can redistribute it and/or modify
12 # it under the terms of the GNU Library General Public License as
13 # published by the Free Software Foundation; either version 2 of the
14 # License, or (at your option) any later version.
16 # This program is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # Library General Public License for more details.
21 # You should have received a copy of the GNU Library General Public
22 # License along with this program; if not, write to the Free Software
23 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
24 # USA
26 # TARGETS
27 # http://microcom.port5.com/m102.tar.gz
28 MICROCOM_SITE:=http://microcom.port5.com/
29 MICROCOM_SOURCE:=m102.tar.gz
30 MICROCOM_DIR:=$(BUILD_DIR)/microcom-1.02
32 $(DL_DIR)/$(MICROCOM_SOURCE):
33 $(WGET) -P $(DL_DIR) $(MICROCOM_SITE)/$(MICROCOM_SOURCE)
35 microcom-source: $(DL_DIR)/$(MICROCOM_SOURCE)
37 $(MICROCOM_DIR)/.unpacked: $(DL_DIR)/$(MICROCOM_SOURCE)
38 mkdir -p $(MICROCOM_DIR)
39 zcat $(DL_DIR)/$(MICROCOM_SOURCE) | tar -C $(MICROCOM_DIR) $(TAR_OPTIONS) -
40 touch $(MICROCOM_DIR)/.unpacked
42 $(MICROCOM_DIR)/.configured: $(MICROCOM_DIR)/.unpacked
43 $(SED) 's~gcc~${TARGET_CC}~' $(MICROCOM_DIR)/Makefile
44 touch $(MICROCOM_DIR)/.configured
46 $(MICROCOM_DIR)/microcom: $(MICROCOM_DIR)/.configured
47 $(MAKE) CFLAGS="$(TARGET_CFLAGS)" -C $(MICROCOM_DIR)
49 $(TARGET_DIR)/usr/bin/microcom: $(MICROCOM_DIR)/microcom
50 install -c $(MICROCOM_DIR)/microcom $(TARGET_DIR)/usr/bin/microcom
52 microcom-clean:
53 rm $(MICROCOM_DIR)/*.o
55 microcom-dirclean:
56 rm -rf $(MICROCOM_DIR)
58 microcom: uclibc $(TARGET_DIR)/usr/bin/microcom
60 #############################################################
62 # Toplevel Makefile options
64 #############################################################
65 ifeq ($(strip $(BR2_PACKAGE_MICROCOM)),y)
66 TARGETS+=microcom
67 endif