[r688746] Define is.unix property in more obvious way.
[harmony.git] / debian / harmony-5.0-jre.postinst
blob093bd79ea92e81ad0bfa42920310f91f3722d3bc
1 #!/bin/sh
2 # postinst script for harmony-5.0-jre
4 # see: dh_installdeb(1)
6 set -e
8 # summary of how this script can be called:
9 # * <postinst> `configure' <most-recently-configured-version>
10 # * <old-postinst> `abort-upgrade' <new version>
11 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12 # <new-version>
13 # * <postinst> `abort-remove'
14 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15 # <failed-install-package> <version> `removing'
16 # <conflicting-package> <version>
17 # for details, see http://www.debian.org/doc/debian-policy/ or
18 # the debian-policy package
21 case "$1" in
22 configure)
23 update-alternatives \
24 --install /usr/bin/java java /usr/bin/java-harmony 30 \
25 --slave /usr/share/man/man1/java.1.gz java.1.gz \
26 /usr/share/man/man1/java-harmony.1.gz
29 abort-upgrade|abort-remove|abort-deconfigure)
33 echo "postinst called with unknown argument \`$1'" >&2
34 exit 1
36 esac
38 # dh_installdeb will replace this with shell code automatically
39 # generated by other debhelper scripts.
41 #DEBHELPER#
43 exit 0